Setup Amazon SES for a Single Domain(s) in Exim (WHM) - Failing SPF in a particular case

UnknownFan

Registered
Jan 19, 2021
3
0
1
Brazil
cPanel Access Level
Root Administrator
Greetings,

I followed the tutorial at Setup Amazon SES for a Single Domain(s) in Exim (WHM), Hummdis

And it worked for most cases when using port 587 on outlook.

However, in two cases, this tutorial causes issues.

A) If the user uses port 465 on outlook, SPF fails and it doesnt use amazon SES
I tried to solve but failed.

B) If the user logs in the webmail, for example, HORDE, SPF fails as below:

Note that, it says My personal computer IP isnt designated to send... But im using Horde in the server, what am I doing wrong?

HTML:
Delivered-To: [email protected]
Received: by 2002:a05:6838:d895:0:0:0:0 with SMTP id ro21csp2296376nkb;
        Sat, 20 Mar 2021 10:06:46 -0700 (PDT)
X-Google-Smtp-Source: ABdhPJyJX5/eYE0v2RflBAx2lUhU81z2OZLocxPMY99P5JhxRZLZPIe4SFafCQRnmpBTKp1YJoyk1wvrauo=
X-Received: by 2002:aca:fc0d:: with SMTP id a13mr4898577oii.133.1616260004876;
        Sat, 20 Mar 2021 10:06:44 -0700 (PDT)
Authentication-Results: mx.google.com;
       spf=softfail (google.com: domain of transitioning [email protected]_REDACTED.com.br does not designate 201.REDACTED.REDACTED.176 as permitted sender) [email protected]_REDACTED.com.br
Received-SPF: softfail (google.com: domain of transitioning [email protected]_REDACTED.com.br does not designate 201.REDACTED.REDACTED.176 as permitted sender) client-ip=201.REDACTED.REDACTED.176;
Received: by 2002:aca:4b89:: with POP3 id y131mf6015847oia.6;
        Sat, 20 Mar 2021 10:06:44 -0700 (PDT)
X-Gmail-Fetch-Info: [email protected]_REDACTED.com.br 3 mail.HOST_REDACTED.com.br 995 [email protected]_REDACTED.com.br
Return-Path: <[email protected]_REDACTED.com.br>
Delivered-To: [email protected]_REDACTED.com.br
Received: from vps-5319928.HOST_REDACTED.ltda by vps-5319928.HOST_REDACTED.ltda with LMTP id IGWCApMrVmBLOQAA+8g9TA (envelope-from <[email protected]_REDACTED.com.br>) for <[email protected]_REDACTED.com.br>; Sat, 20 Mar 2021 14:06:27 -0300
Return-path: <[email protected]_REDACTED.com.br>
Envelope-to: [email protected]_REDACTED.com.br
Delivery-date: Sat, 20 Mar 2021 14:06:27 -0300
Received: from localhost ([127.0.0.1]:53082 helo=vps-5319928.HOST_REDACTED.ltda) by vps-5319928.HOST_REDACTED.ltda with esmtpsa
  (TLS1.2) tls TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 (Exim 4.94) (envelope-from <[email protected]_REDACTED.com.br>) id 1lNf3S-0003ps-VX for [email protected]_REDACTED.com.br; Sat, 20 Mar 2021 14:06:26 -0300
Received: from [201.REDACTED.REDACTED.176] ([201.REDACTED.REDACTED.176]) by vps-5319928.HOST_REDACTED.ltda (Horde Framework) with HTTPS; Sat, 20 Mar 2021 14:06:26 -0300
Date: Sat, 20 Mar 2021 14:06:26 -0300
Message-ID: <[email protected]_REDACTED.ltda>
From: [email protected]_REDACTED.com.br
To: USER_REDACTED <[email protected]_REDACTED.com.br>
Subject: a
User-Agent: Horde Application Framework 5
Content-Type: text/plain; charset=utf-8; format=flowed; DelSp=Yes
MIME-Version: 1.0
Content-Disposition: inline
--Sem título.png

--

Please help!
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,871
601
273
cPanel Access Level
Root Administrator
Hey there! It's important to note that tutorial isn't something we created, so I can't be sure if all the steps there are correct.

It sounds like there is a mixup in the IPs that are configured as permitted senders if you are getting that error message, as messages sent from Horde should definitely be showing the server's IP.

It might be worth it to reach out to the creator of that post to see if they have additional ideas as well, as it is only a few months old.