The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Severely limited versions of PHP

Discussion in 'EasyApache' started by earthrat, Oct 28, 2014.

  1. earthrat

    earthrat Active Member

    Joined:
    Nov 8, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bend, OR
    cPanel Access Level:
    Root Administrator
    We just got moved to a new server and found that the available versions of PHP (5.4.34 & 5.5.18) will not run the versions of Joomla that we currently have. Why does cPanel insist on only giving such limited choices of PHP to load? I do not see why there is so much inconsistency between cPanels on these servers and why I am forced to choose between versions that do not support the software that I need and now we are forced to run with a deprecated version of PHP because the version we had before is not available. Thankfully I discovered CloudLinux otherwise I don't know what I would do?
     
    #1 earthrat, Oct 28, 2014
    Last edited: Oct 28, 2014
  2. lorio

    lorio Well-Known Member

    Joined:
    Feb 25, 2004
    Messages:
    243
    Likes Received:
    3
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    What Joomla version is used?
    Looks quite good for the versions which are not EOL
    Technical Requirements
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Have you considered upgrading the installations of Joomla? If you are using an outdated version of Joomla that only supports older versions of PHP, then it's possible that it's vulnerable to exploits.

    Thank you.
     
  4. earthrat

    earthrat Active Member

    Joined:
    Nov 8, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bend, OR
    cPanel Access Level:
    Root Administrator
    Thanks for the replies, I am running both 2.5 and 3.3 sites. The thing is before we moved to the new server everything was working great. The DC moved us and still all was working fine but cURL was not installed and after Apache was recompiled PHP was updated to the only version that was given to us and after that all the sites crashed. The DC techs worked on this for hours having issues with the recompile saying that it ran out of memory due to YUM, did a manual update of YUM and then recompiled again and said all was well. However all is not well because they said they had to compile with PHP 5.3. Now some sites work while others are totally blank. I have a total mess on my hands and the only thing that seems to be messed up is the fact that the PHP version I had is not available. Is there a way to get a different version of PHP that is not available in EasyApache?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    No, but you could review the Apache error log or the error_log files within the accounts to get a better idea of why blank pages are served when the website is accessed.

    Thank you.
     
  6. earthrat

    earthrat Active Member

    Joined:
    Nov 8, 2010
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Bend, OR
    cPanel Access Level:
    Root Administrator
    Not sure why, but the default install had Suhosin loaded and that is what was causing all my problems.
     

Share This Page