Jul 19, 2015
5
1
53
nirvana
cPanel Access Level
Root Administrator
For the folder field of the backup configuration:
/yourdirectory => WRONG
/yourdirectory => WRONG
yourdirectory/ => GOOD!
Try in your terminal:
sftp '[email protected]'@ftp.adrive.com:yourdirectory/
to see whether it works or not
When setting up the backup to a remote location, I get this error:
"
Error: Validation for transport “c1” failed: Could not upload test
file: Couldn't open remote file '/validate.tmp-27690-1501312901.txt':
Permission denied
"

It is very strange that cpanel does not include a proper hint/explanation/example exactly where this is needed (in the backup setup underneath the heading but before the input field of the backup path), since leaving it with the default "/" yields a permission error (which is hard to figure out and the quoted post above was the only hint available, as cpanel help does not explain it). Insufficient care and testing is again the reason for this. And it is over a year...perhaps get some interns to test?

(side note: The whole design of that backup setup is not very clear
and it is not straight forward either re which keys, etc. I suggest
you test a lot more with people who are not whm/cpanel experts and
who've no time, b/c such constraints reveal better what's needed.)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello @WizardOfYonder,

Could you verify if switching to the "yourdirectory/" or leaving the field blank results in the same error message? If so, could you verify if the remote SFTP server you are configuring runs Windows 10? There's an internal case open to address a related issue:

Backup to remote has auth issues

Thank you.
 
Jul 19, 2015
5
1
53
nirvana
cPanel Access Level
Root Administrator
Hello @WizardOfYonder,

Could you verify if switching to the "yourdirectory/" or leaving the field blank results in the same error message? If so, could you verify if the remote SFTP server you are configuring runs Windows 10? There's an internal case open to address a related issue:

Backup to remote has auth issues

Thank you.
When trying the first time, the field contained "/" and brought up the quoted error message. Then later "/yourdirectory" was tried, with the same result. Only after reading the previously quoted post by @kiti was "yourdirectory/" tried and worked.
Both ftp servers are pure-ftp on two same version WHM/cPanel.

However, to my surprise, when setting this up today again, neither empty field nor plain name without forward slashes (front or back) brought up any error!?! Also, when the plain directory name was used with a digit at the end "yourdirectory2" it ignored it and used "yourdirectory" only?!?

No clue how this is possible, but maybe (there is more intel in it and) 'it found' old backups there and 'thought' it was 'the right' directory ;)

Thanks for looking into it!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
However, to my surprise, when setting this up today again, neither empty field nor plain name without forward slashes (front or back) brought up any error!?! Also, when the plain directory name was used with a digit at the end "yourdirectory2" it ignored it and used "yourdirectory" only?!?
Could you open a support ticket using the link in my signature so we can take a closer look?

Thank you.
 
Jul 19, 2015
5
1
53
nirvana
cPanel Access Level
Root Administrator
Could you open a support ticket using the link in my signature so we can take a closer look?

Thank you.
Very kind of you, it works now, so no need to waste resources.
(And the digit at the end was in the name, not the directory, as I found later (must have been tired 4am), so this is not a surprise/bug, but mea culpa spotting a non-error/false alarm. But the other stuff happened that way.)
Thx :)