Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

sh script to update PHP-Nuke install pkg to current version

Discussion in 'cPanel Developers' started by SeanHogan, May 21, 2004.

  1. SeanHogan

    SeanHogan Member

    Joined:
    Jan 16, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    I modified the script written by Al Smith in thread... http://forums.cpanel.net/showthread.php?s=&threadid=15097 to update the phpnuke install pkg to the current version ( 7.2 at this time ).

    In cpanel it still shows 6.8, and I don't think it lets you upgrade a previous install ( I didn't have 6.8 installed so I couldn't test that ).

    Hopefully this will be helpful to some of you....
    (It works for me)

    Code:
    #!/bin/sh
    
    # getnuke.sh
    # seanhogan.us 20May04
    # Based on Al Smith 09-01-2003 
    # Update cpanel PHP Nuke pkg.tar.gz file to current version
    
    Version=PHP-Nuke-7.2.zip             # Version to fetch
    NukeHome=/usr/local/cpanel/addons/PHP-Nuke   # Cpanel addon dir for PHP-Nuke
    NukeFile=pkg.tar.gz                           # Cpanel file name
    Source=http://phpnuke.org/files/
    
    mkdir /tmp/Nuke 
    cd /tmp/Nuke
    
    mkdir pkg
    cd pkg
    
    wget $Source/$Version  # Get the version
    
    unzip $Version
    
    mv *.zip /tmp  # move the .zip file out
    
    cd /tmp/Nuke
    tar cvfz $NukeFile pkg   # Create the pkg file
    
    cp $NukeFile $NukeHome   # Copy the pkg to the Nuke Home
    
    rm -rf /tmp/Nuke     # Clean up the mess
    
    #
    #  End
    #
    # TO DO:  
    # update cpanel to show current nuke version (shows 6.8 now)
    # make cpanel work with upgrading previous version of nuke
    
     
  2. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    506
    Likes Received:
    4
    Trophy Points:
    168
    cool, did it work properly
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. SeanHogan

    SeanHogan Member

    Joined:
    Jan 16, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    Yes, but the pages in CPanel still show 6.8, and I don't know if the upgrade php-nuke install option in CPanel will work with this, because I didn't have a previous version of php-nuke installed by Cpanel.

    Your original script helped me when it was version 6.8 or 6.9.
    Thanks for your help!

    ~Sean
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice