shared ip address redirect to the 1st account domain!

egycode

Registered
May 6, 2010
1
0
51
Hello,

I have a problem like this but I think the reverse, I have a VPS with control panel VZPP.

My problem is the server default page /cgi-sys/defaultwebpage.cgi not like they reported here, it redirect to 1st account domain name! I tried to rebuild configuration but with no hope.:eek:

The cpanel version is 11.25.0-CURRENT_45139

Thanks in advance.
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Friendly Moderator Note

Hello,

I have a problem like this but I think the reverse, I have a VPS with control panel VZPP.

My problem is the server default page /cgi-sys/defaultwebpage.cgi not like they reported here, it redirect to 1st account domain name! I tried to rebuild configuration but with no hope.:eek:

The cpanel version is 11.25.0-CURRENT_45139

Thanks in advance.
To prevent possible confusion this request has been forked (separated) from an older topic.

For reference, here is the older thread: fresh install won't show default apache page - cPanel Forums
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
Hello,

I have a problem like this but I think the reverse, I have a VPS with control panel VZPP.

My problem is the server default page /cgi-sys/defaultwebpage.cgi not like they reported here, it redirect to 1st account domain name! I tried to rebuild configuration but with no hope.:eek:

The cpanel version is 11.25.0-CURRENT_45139

Thanks in advance.
Based on the information provided it's difficult for me to ascertain a precise diagnosis, but I believe there is a chance the issue may be resolved by regenerating the Apache server configuration (httpd.conf); this may be performed by entering the following two commands via root SSH access, followed by re-testing to verify if the same issue is still present:
Code:
# /scripts/rebuildhttpdconf
# /scripts/restartsrv_httpd
It would help greatly to know some additional information; please let us know any additional details that you believe may help us better understand and investigate the issue that is being experienced. Where possible, please provide us with at least the following details that I have numbered for clarity.

  • 1.) What is the original URL or web site address that is being requested or accessed in a browser that eventually triggers seeing the described symptom? To help clarify, are any of the following examples similar? In these examples, I used $IP to represent any server IP address, and $DOMAIN to represent any domain name on the server, such as a cPanel account domain or the server hostname.
    Code:
    http://$IP/
    http://$DOMAIN/
    http://$IP/cgi-sys/defaultwebpage.cgi
    http://$DOMAIN/cgi-sys/defaultwebpage.cgi
  • 2.) After requesting the specific URL or web site address, does it redirect to a different URL or address, similar to any of the aforementioned examples? To clarify, what is the final URL or final web site address seen in your browser?
  • 3.) Please confirm if any of the following descriptions may be accurate or very similar to the issue being experienced:
    • A.) The access attempt to the URL being requested may be redirected to a specific domain name, that is, a change in the URL or web site address displayed by your browser, different than the URL or address originally requested. For example, accessing http://domain1.tld/ is redirected to http://domain2.tld/ thus causing content for domain2.tld to be displayed.
    • B.) When accessing the requested URL this may result in displaying the (unexpected) web site content of a specific domain, such as the first (1st) account's domain name as seen in the Apache virtual host configuration, that is different than the domain or address originally requested. For example, accessing http://domain1.tld/ stays on the same URL for domain1 but displays content that is expected only when accessing http://domain2.tld/
    • C.) Accessing the server by requesting a specific IP address, without involvinv a domain name, results in having content for a specific domain name displayed and not the expected default web page. For example, accessing http://$IP/ displays content for a specific domain and does not redirect so the the URL stays at the same address.
 

Spiral

BANNED
Jun 24, 2005
2,018
8
193
My problem is the server default page /cgi-sys/defaultwebpage.cgi not like they reported here, it redirect to 1st account domain name! I tried to rebuild configuration but with no hope.:eek:
Reading from the top of the /usr/local/apache/conf/httpd.conf file downward, the first virtualhost section encountered for any given IP address will be the "default" page for that IP address