Shared SSL Cert Enabled - Setting Location?

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
I believe this is the issue:

http://hostname/~username <-- THIS WORKS

https://hostname/~username <-- THIS DOES NOT WORK AT ALL

This has nothing to do with mod_userdir, which causes ~username to not work at all.

The only issue is that http works, and https does NOT work, and there seems to be nowhere in whm to change/reset this issue.

Please look into this. Thanks!
Have you ever started Apache manually via SSH? Most people when they start Apache from the command line forget to run Apache with SSL support. The easiest way to attempt a resolution would be to restart Apache via WHM.
 

jandafields

Well-Known Member
May 6, 2004
436
6
168
USA
cPanel Access Level
Root Administrator

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Restarting with WHM does not help.

The issue with restarting in SSH has been resolved already:
http://bugzilla.cpanel.net/show_bug.cgi?id=7101

I should note that
https://some.domain.with.cert.com <-- WORKS
https://hostname.com/~username <-- DOES NOT WORK
http://hostname.com/~username <-- WORKS

This is the case for me, and this seems to be similiar to the case for other people in this thread.
Please expand on what you mean by "Does not Work" as it is a very vague phrase.
 

jandafields

Well-Known Member
May 6, 2004
436
6
168
USA
cPanel Access Level
Root Administrator

hydra

Well-Known Member
Mar 26, 2008
102
1
68
Amsterdam, Netherlands
Hi,

Probably not useful info for the solution but this all is working as it should on my cpanel setup. No problems at all.
I am using WHM 11.23.2 cPanel 11.23.4-C26066

If you would like me to check some settings or something else let me know.

Ronald.