The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

shared SSL not working

Discussion in 'General Discussion' started by kipper3d, Oct 15, 2008.

  1. kipper3d

    kipper3d Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    shared SSL is not working when customers use it for shared SSL but it works when logging into WHM and cpanel. Is there a new configuration that got turned off recently?

    Error from firefox: SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)


    Version: WHM 11.23.2 cPanel 11.23.6-R27698

    Any ideas? Thanks!

    -John
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  3. kipper3d

    kipper3d Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Thanks Nick,

    I have done this cPanel tickets ID# 321250

    However, tech is telling me I need 2 certificates for the same domain on the same IP. Says that cert 1 only works on https://hostname.net:2087 but have to get another cert for the same domain as user nobody so that it will work on https://hostname.net/~username/path

    Im sorry but Im not buying that. I think theres a problem with openSSL. SSL works for one domain, 1 IP. Should have nothing to do with ports.

    The certificate we bought and installed last February has worked for both the whm/cpanel login and the shared SSL until now.

    Thanks!

    -John
     
Loading...

Share This Page