SOLVED Shell Access - Not being enabled

Fr3DBr

Member
Apr 6, 2013
21
1
3
The Netherlands
cPanel Access Level
DataCenter Provider
Twitter
Hi, guys.

Currently I'm using WHMCS+cPanel+CloudLinux. In my "package" in both cPanel and WHMCS, I've selected the option to "enable shell access".

Although, when new accounts are created, the shell is still disabled.

Additionally, if you upgrade/downgrade the package of one account via "Change Package" in WHMCS, if you had previously enabled shell access, this is lost, resulting in disabled shell again.

Could you tell me what is wrong ?

I've attached the screenshots of current settings, ensuring shell had to be always enabled (for all whmcs products/services and cPanel packages we have).
 

Attachments

Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Additionally, if you upgrade/downgrade the package of one account via "Change Package" in WHMCS, if you had previously enabled shell access, this is lost, resulting in disabled shell again.
Hello,

Are you able to reproduce the same behavior in Web Host Manager using "WHM >> Upgrade/Downgrade an Account"? If not, I recommend reporting the issue to the WHMCS support team. You can find the WHMCS forums at:

WHMCS Community Forums

Thank you.
 

Fr3DBr

Member
Apr 6, 2013
21
1
3
The Netherlands
cPanel Access Level
DataCenter Provider
Twitter
Hello,

Are you able to reproduce the same behavior in Web Host Manager using "WHM >> Upgrade/Downgrade an Account"? If not, I recommend reporting the issue to the WHMCS support team. You can find the WHMCS forums at:

WHMCS Community Forums

Thank you.
Hi, Michael.

You're right, by using upgrade/downgrade function from WHM this issue doesn't happens, which means it's probably WHMCS not sending the shell (enabled/disabled option) the way we've selected it in the module settings to WHM, at least, this sounds to be the issue from the way it looks like.
 

Fr3DBr

Member
Apr 6, 2013
21
1
3
The Netherlands
cPanel Access Level
DataCenter Provider
Twitter
Nevermind, this wasn't a bug, just that I had the option to prevent a reseller creating accounts with shell access enabled. ;) Too many settings to look at, if a detail is skipped, you know... :)
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
I'm happy to see you were able to determine the cause of the issue. Thank you for updating us with the outcome.