The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shell Access Problem

Discussion in 'General Discussion' started by mixx941, Jul 5, 2006.

  1. mixx941

    mixx941 Well-Known Member

    Joined:
    Oct 28, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Hi everyone. I'm not sure if this is a bug, but I now see that it has happened on two accounts. I created the accounts via WHM and checked the "Shell Access" box on account creation. After creating, I notice that they have /bin/sh as their shell instead of bash. In the "Manage Shell Access" screen, the only options are to "Disable" or "Enable Jailed Shell". If I click "Enable Jailed Shell", it will enable the jailshell but the WHM screen stays the same showing /bin/sh with the only options still being "Disable" or "Enable Jailed Shell".

    I've even deleted one of the accounts and re-created several times trying to fix another problem with reseller permissions, but re-creating without the "Shell Access" box checked and then trying to assign after doesn't help either, as it still shows /bin/sh as the shell and still only gives me "Disable" and "Enable Jailed Shell". I've fully refreshed the page as well to make sure it wasn't my browser showing a cached page with the wrong information or something.

    How can I fix this and be able to assign "Normal Shell" to these accounts? Can I use FreeBSD's `chsh` command to assign bash, or will that mess something up in cPanel/WHM?

    Thanks in advance.

    -Mark
     
  2. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Not sure what's going on with WHM there, but yes, the chsh command works fine.
     
Loading...

Share This Page