The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Show dot files in Proftpd?

Discussion in 'General Discussion' started by Jeff75, Aug 6, 2003.

  1. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Can somebody tell me what setting I need to add to the config file for Proftpd so dot files (such as .htaccess) can be seen by default? I don't want to have each client have to add the flag in their FTP client just to show this.

    cPanel.net Support Ticket Number:
     
  2. anand

    anand Well-Known Member

    Joined:
    Nov 11, 2002
    Messages:
    1,435
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    DataCenter Provider
    You would need to edit each virtual user account setup in /etc/proftpd.conf and add the following:

    ShowDotFiles On

    Please note that in proftpd docs also this is mentioned that this has been depreciated and can be removed in future.

    I am not even sure if it works now or has been removed altogether. Its recommended to modify your ftp client and then get the listing of . files with ls -al.

    cPanel.net Support Ticket Number:
     
  3. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    I've tried to enable dot files in my proftpd.conf file but for some reason when I go to start proftpd it comes up with this.

    - Fatal: unknown configuration directive 'ShowDotFiles' on line 67 of '/usr/local/etc/proftpd.conf'.

    I don't understand because I have "ShowDotFiles on" on it's on seperate line. I've also read the documentation for Proftpd at http://www.castaglia.org/proftpd/doc/contrib/contextual-directive-index.html and I have everything set up correctly.

    Does anybody know why it's not allowing me to use this directive?

    cPanel.net Support Ticket Number:
     
  4. www-lab

    www-lab Well-Known Member

    Joined:
    Feb 1, 2003
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    I had the same problem and it seems that proftpd is just not compiled with all modules

    cPanel.net Support Ticket Number:
     
  5. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    ahhhhh!!! Does anybody know how to recompile it with the ShowDotFiles module enabled?

    cPanel.net Support Ticket Number:
     
  6. FWC

    FWC Well-Known Member

    Joined:
    May 13, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ontario, Canada
    Add this to proftpd.conf toward the top, above the virtual hosts. It works:
    Code:
    <Global />
    ListOptions "-a"
    </Global>
     
  7. Jeff75

    Jeff75 Well-Known Member

    Joined:
    Apr 11, 2003
    Messages:
    555
    Likes Received:
    0
    Trophy Points:
    16
    Thanks FWC!!!!!!!!!

    cPanel.net Support Ticket Number:
     
  8. taotoon

    taotoon Well-Known Member

    Joined:
    Nov 14, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16

    It works with ProFTPD 1.2.10 Server.
    I added to the topmost line 1.

    Thank you very much.
     
Loading...

Share This Page