Shutdown halts with many Unmounted /home/virtfs

hicom

Well-Known Member
May 23, 2003
290
4
168
Hi, we were doing a kernel upgrade on the server

from: 3.10.0-693.11.6.el7.x86_64
TO: 3.10.0-693.11.6.el7.x86_64

We issued a reboot command, however, the system hung and kept recycling at the following screenshot (we had to hard reset it):

upload_2018-5-20_14-13-31.png

The system hangs at: "Reached target Shutdown"

Here is some more information on our setup, any suggestions:
  • CENTOS 7.4 standard
  • WHM v68.0.38
  • JailShell enabled
  • Enabled: EXPERIMENTAL: Jail Apache Virtual Hosts using mod_ruid2 and cPanel® jailshell.
  • Enabled: Use cPanel® jailshell by default
  • Jailed /proc mount method: "Mount limited /proc for RHEL, CentOS, and CloudLinux™ 6, Full /proc for RHEL, CentOS, CloudLinux, or xenpv 5 or 7 default"
  • Jailed /bin mounted suid: off
  • Jailed /usr/bin mounted suid: off

Everything works fine after reboot.

One other question, once rebooted, Apache does not start automatically even though its checked in the services. We usually start it up manually.

thanks..
 
Last edited by a moderator:

24x7server

Well-Known Member
Apr 17, 2013
1,911
96
78
India
cPanel Access Level
Root Administrator
Twitter
Hi,

The system hangs at: "Reached target Shutdown"
This may have to be checked, but you are not alone with this issue. If you search "Reached target Shutdown" on google, you will lot of results. Try updating your system..

One other question, once rebooted, Apache does not start automatically even though its checked in the services. We usually start it up manually.
reenable the service
# systemctl disable httpd
# systemctl enable httpd
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,297
1,251
313
Houston
Hi @hicom Agree with @24x7server on this one, furthermore, can you let us know if after following the advice provided if httpd continues to have the same issue?

Thanks!
 

hicom

Well-Known Member
May 23, 2003
290
4
168
Thanks, will try it. Won't know until the next reboot. The "Target Shutdown" issue didn't happen on previous reboots so I am a bit hesitant to believe its in the OS. The screen kept saying Unmounted /home/virtfs/ then cycles again to "Target Shutdown".