The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

£ sign is showing as ?

Discussion in 'Database Discussions' started by quats, Mar 13, 2008.

  1. quats

    quats Member

    Joined:
    Mar 11, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    When I have data from the mysql database that uses the £ symbol it is showing as a ? does any one now how to get his to show correctly.
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It sounds like a character encoding issue.

    Is it stored as £ in the MySQL database? If so, then check the character encoding of the script that is displaying that symbol, ensure it is a character set that contains the £ symbol.
     
  3. quats

    quats Member

    Joined:
    Mar 11, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Don't think its the script as it was installed on another server fine without this problem, also from what I can see only the figure is saved in the database and not the symbol.

    It is a oscommerce shop if that helps
     
  4. quats

    quats Member

    Joined:
    Mar 11, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    No worry problem solved, seems when imported the database across the £ must have been converted to ? so once updated that field in the database it worked.

    Thanks for your help though.
     
Loading...

Share This Page