The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sim started restarting Apache, but then it kept failing?

Discussion in 'EasyApache' started by noimad1, Jul 4, 2005.

  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I would post this at the sim (rfnetworks forum) but it doesn't seem to be up.

    On two servers this morning I had the same thing happen. All of a sudden SIM started restarting httpd over and over again. It was saying this in the log:

    Jul 4 14:06:02 h4 sim[652]: {init.httpd} url-aware check: failed for http://127.0.0.1:80/

    So the 127.0.0.1:80 was failing, but if I restarted httpd myself I could access websites without a problem. Then if I ran SIM manually it would say it was failed and try to restart it again, then apache would fail?

    Anyone have any ideas on why the httpd://127.0.0.1:80/ would fail?
     
  2. lankyb

    lankyb Well-Known Member

    Joined:
    Sep 21, 2004
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Peterborough, UK
    this is probably a really stupid question, but what is SIM?
     
  3. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16

    Sorry, SIM is a monitoring script that moniters all of your services and restarts them if they are down.

    You can download it from:

    http://rfxnetworks.net/

    That along with their PRM can really be life savers.
     
  4. lankyb

    lankyb Well-Known Member

    Joined:
    Sep 21, 2004
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Peterborough, UK
    After reading the documentation that comes with SIM, all i can suggest is make sure that you have an up-to-date version of the software. This can be simply done by the following command into SSH:

    Code:
     /usr/local/sim/sim -u 
    This will check for any updates available for SIM. I also suggest peforming a full update with cPanel, and to also check the error log file for Apache... see if that helps.

    Code:
    To do a full forced update, type the following:
    /scripts/upcp --force
    
    To view the apache error log, please view the following file:
    /usr/local/apache/logs/error_log
    I am not actually sure if this is the correct error log, please correct me if i'm wrong :confused:
     
  5. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16

    I am running the version 3.0 of sim, which I am pretty sure is the latest version. the /usr/local/bin/sim -u doesn't do anything....

    I'll try to do another update of cpanel and see if that changes anything....
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Why don't you simply disable SIM from checking httpd since cPanel already comes with a daemon checker (chkservd) anyway and running them both to check the same daemons is asking for trouble as it would be very easy to get into a infinite-loop.
     
  7. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    Because I always have trouble with chkservd. Sometimes it will fail as well and won't pick up the restarts when it is supposed to.

    I've never had any problems running the two at the same time.
     
Loading...

Share This Page