The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Simplifying ionCube Options

Discussion in 'EasyApache' started by Josh Abbott, Oct 15, 2016.

  1. Josh Abbott

    Josh Abbott Member

    Joined:
    Oct 4, 2015
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    I noticed that EasyApache 4 now has three different options to install the ionCube loaders: v4, v5, and v6. Since each version is designed to be fully backwards-compatible with all previous versions of the loaders, it seems redundant and unnecessarily complicated to list so many older versions of the loaders for each version of PHP.

    I recommend offering two options "Latest" and "Stable" and have the latest option pull the most recent loader directly from ionCube's web site, for those who always want the newest version without waiting for cPanel to implement it. If it would be impractical for EA4 to connect directly to ionCube, then perhaps an automated script could check for daily updates from ionCube, and then download those updates to cPanel's servers for EA4 to retrieve.

    Then the "Stable" option could contain an older version that has been well-tested. It would be great if both options updated automatically, so server administrators could simply select an update tier rather than reprovision EA4 each time a new version of ionCube is available.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello Josh,

    Thank you for the valuable feedback.

    We currently offer multiple versions of IonCube Loader for each PHP version. This allows users that want to utilize IonCube Loader 6 the ability to do so, while also allowing users that want to use IonCube Loader 4 or 5 the option to continue using those versions. While backwards compatibility does exist, some users prefer to wait while initial bugs are resolved. For instance, four new updates were released since September for IonCube 6:

    ionCube News - PHP Encoder, protection, installer and performance tools from ionCube

    Documentation on IonCube Loader 6 and IonCube Loader 5 is available at:

    PHP Loader: ionCube 6 - EasyApache 4 - cPanel Documentation
    PHP Loader: ionCube 5 - EasyApache 4 - cPanel Documentation

    That said, I do encourage you to open a feature request for the simplification of the IonCube Loader package availability and installation via:

    Submit A Feature Request

    There's an article here that explains how feature requests are utilized to provide feedback to our development team:

    How to use and what to expect from the cPanel features site | Guides

    Thanks!
     
Loading...

Share This Page