The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sites late online after server reboot

Discussion in 'General Discussion' started by Archmactrix, Aug 10, 2014.

  1. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    On my server, almost all my sites are extremely late online after server reboot, or up to half an hour or so. :)

    I didn't have this problem before until I noticed this last winter. I reboot the server when it has been online for 2-3 months.

    This is Apache 2.4 web server on a VPS.
     
  2. iserversupport

    iserversupport Well-Known Member

    Joined:
    Nov 4, 2013
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Is it an ongoing issue ? Maybe the reason is fsck check on server reboot
     
  3. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I'm not sure if that is reason as the server is up and running, and all cPanel control panels and one site online, but just several sites down for about half an hour.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,832
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Is Apache running when the websites are not accessible? What do you see in /usr/local/apache/logs/error_log after the reboot if it's running?

    Thank you.
     
  5. Archmactrix

    Archmactrix Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    132
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I didn't see anything in the apache error log at that time so I rebooted the server again to see if I might find something new.

    1. Apache server was up and running within a minute
    2. One site was online within at least two minutes, exactly as happened last time with the same site
    3. But the other two sites were not online, exactly as happened last time
    4. One of these two was online after about 20 minutes
    5. The other one online after more then 30 minutes
    Within few minutes from reboot these were entries in Apache server status page:

    The client IP's in front of the server IP are all mine when one site was online but the other one's not.

    xx.2x9.xx8.2xx
    xx.2x9.xx8.2xx xx.1xx.xx6.x:80 NULL
    xx.2x9.xx8.2xx
    xx.2x9.xx8.2xx xx.1xx.xx6.x:80 NULL

    Apache error log:

    Code:
    [Mon Aug 11 18:42:03.443517 2014] [mpm_prefork:notice] [pid 1245] AH00169: caught SIGTERM, shutting down
    [Mon Aug 11 18:42:32.001932 2014] [ssl:warn] [pid 1247] AH01906: server.xxxxxxx.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Aug 11 18:42:32.002455 2014] [suexec:notice] [pid 1247] AH01232: suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Mon Aug 11 18:42:32.002523 2014] [:notice] [pid 1247] ModSecurity for Apache/2.8.0 (www.modsecurity.org/ ModSecurity: Open Source Web Application Firewall) configured.
    [Mon Aug 11 18:42:32.002537 2014] [:notice] [pid 1247] ModSecurity: APR compiled version="1.5.1"; loaded version="1.5.1"
    [Mon Aug 11 18:42:32.002546 2014] [:notice] [pid 1247] ModSecurity: PCRE compiled version="8.35 "; loaded version="8.35 2014-04-04"
    [Mon Aug 11 18:42:32.002553 2014] [:notice] [pid 1247] ModSecurity: LUA compiled version="Lua 5.1"
    [Mon Aug 11 18:42:32.002559 2014] [:notice] [pid 1247] ModSecurity: LIBXML compiled version="2.9.1"
    [Mon Aug 11 18:42:32.002566 2014] [:notice] [pid 1247] Status engine is currently disabled, enable it by set SecStatusEngine to On.
    [Mon Aug 11 18:42:33.001166 2014] [ssl:warn] [pid 1263] AH01906: server.xxxxxxx.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Aug 11 18:42:33.002798 2014] [:notice] [pid 1263] mod_ruid2/0.9.8 enabled
    [Mon Aug 11 18:42:33.018560 2014] [mpm_prefork:notice] [pid 1263] AH00163: Apache/2.4.10 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
    [Mon Aug 11 18:42:33.018603 2014] [core:notice] [pid 1263] AH00094: Command line: '/usr/local/apache/bin/httpd -D SSL'
     
    #5 Archmactrix, Aug 11, 2014
    Last edited: Aug 11, 2014
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,832
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page