The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sites only loading cpanel default page

Discussion in 'General Discussion' started by cyspan, Feb 19, 2008.

  1. cyspan

    cyspan Registered

    Joined:
    Feb 18, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have a cpanel server version 11. I have 3 domains configured in the server. The issue is all the 3 domains is showing the cpanel default page from /usr/local/apache/htdocs/. It is not taking the virtual domain document from /home/<username>/public_html. All the domains contain index file at document root. Giving below conf file

    -------------------------------------------------------------------------
    # SUEXEC is supported

    Include "/usr/local/apache/conf/includes/pre_virtualhost_global.conf"
    Include "/usr/local/apache/conf/includes/pre_virtualhost_2.conf"

    # DO NOT EDIT. AUTOMATICALLY GENERATED. IF YOU NEED TO MAKE A CHANGE PLEASE USE THE INCLUDE FILES.
    NameVirtualHost xxx.xxx.xxx.xxx:80
    NameVirtualHost *

    # Default vhost for unbound IPs

    <VirtualHost *>
    ServerName ip-xx-xx-xx-xx.ip.secureserver.net
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin user@domain.com
    </VirtualHost>

    # DO NOT EDIT. AUTOMATICALLY GENERATED. IF YOU NEED TO MAKE A CHANGE PLEASE USE THE INCLUDE FILES.

    <VirtualHost xx.xx.xx.xx:80>
    ServerName domain.com
    ServerAlias www.domain.com
    DocumentRoot /home/domain/public_html
    ServerAdmin webmaster@domain.com
    UseCanonicalName Off
    CustomLog /usr/local/apache/domlogs/domain.com combined
    CustomLog /usr/local/apache/domlogs/domain.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    ## User ismuser # Needed for Cpanel::ApacheConf
    <IfModule !mod_disable_suexec.c>
    SuexecUserGroup ismuser ismuser
    </IfModule>
    ScriptAlias /cgi-bin/ /home/domain/public_html/cgi-bin/

    </VirtualHost>
    ----------------------------------------------------------------------------------------

    I have tried many configuration options, but not getting the desired result. I have even recompiled apache with basic configuration but all failed. I am afraid i am missing something. Please help me.
     
  2. tish

    tish BANNED

    Joined:
    Feb 24, 2004
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
Loading...

Share This Page