sites with http redirected to cgi-sys/defaultwebpage.cgi

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
624
59
103
Houston, TX
cPanel Access Level
Root Administrator
Hey there!

As Varnish is not software we support at cPanel, I am limited in regards to what information I can provide. Default page errors like this occur when there is a disconnect between a request being received in a browser and the Apache webserver. The most common cause is an IP mismatch; where the IP address assigned to a domain in the Apache configuration differs from the IP address the domain is pointing to at the DNS level. Or, the domain simply doesn't exist on the server.

There could also be an issue with how the Apache ports are assigned in the virtual host configuration, considering you moved the Apache port to 8080.

We have an article written that should help you in troubleshooting this default page issue.


Don't hesitate to reach out if you have more questions!
 

James Eco

Member
Dec 2, 2020
19
0
1
Israel
cPanel Access Level
Root Administrator

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
624
59
103
Houston, TX
cPanel Access Level
Root Administrator
Troubleshooting this issue further would require a review of your Apache virtual hosts, userdata, etc... Which contain sensitive information. Because of this, could you open a ticket using the link in my signature and update me with the incident ID? That way I can keep this thread updated regarding the findings of the investigation.

Thanks!
 

martin MHC

Well-Known Member
Sep 14, 2016
220
36
78
UK
cPanel Access Level
Root Administrator
Does this help:


As an aside I'm a little confused by the wording of " when using just http " ... as in, what where you using before? https? You should be using https whereever possible.
 
Last edited:
  • Like
Reactions: cPanelAnthony