Slow login to webmail and sending mail through webmail ?

Hack

Member
May 18, 2005
13
0
151
I think I have been bitten by the 11.30.0 build 16 bug list as my server was working great for months and approx two days ago it started having long login delays when my customers log into their webmail. Also when they send email through the webmail it has a long delay. I searched the forums and saw some of the other bugs that have been reported but not this one, or maybe I missed it. I have looked in every log file I can think of and only found the errors that are related to bugs already reported. Any ideas where I might look for why this login delay might be happening.

Thanks.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Hack,

I'm not seeing anything in our ticketing system nor our internal cases indicating an issue with webmail slowness for login or sending. Can you please open up a ticket using WHM > Support Center > Contact cPanel or the link in my signature for us to investigate this further? Please post the ticket number upon submitting one if you would be able to do so.

Also, your server load hasn't increased in any substantial way to account for a generalized server slowdown, has it?

Thanks!
 

Hack

Member
May 18, 2005
13
0
151
I bought my license through BuyCpanel.com and it gave me the option to contact them, but also gave me the option to open the ticket with Cpanel directly. After I got through entering all the info and hitting submit.. I got.

Support Request SubmissionYour support request has been submitted.
Thank you for submitting your request to cPanel. You should receive a confirmation of your request to the email address you provided. A technical support representative will be reviewing your issue soon. Please be available by email for any questions that our representatives may have.



Please be sure to allow ssh access to your server from the follow IP addresses so our support representatives can troubleshoot your issue:

208.XX.XX.XXX
208.XX.XX.XXX
208.XX.XX.XXX
Return to support center

Submission failed! Email address is missing from database or request.

So I'm not sure if it went through or not.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Hack,

If it went through, you should receive an automated response from our system to the email address provided. If you didn't receive any such email, then please try to submit a request again to the system and ensure that the email address field is filled in if it might not have been previously.

Thanks again.
 

Hack

Member
May 18, 2005
13
0
151
I sent buycpanel support an email. hopefully they will open up the ticket with you guys about this.
 

Hack

Member
May 18, 2005
13
0
151
Ughhh, not sure they understand the problem.

They pointed me at.

SquirrelMail - Webmail for Nuts!

After further testing I have figured out that the users have the auto login into roundcube setup. So after they log in they get the "you will be taken into roundcube in 1...2...3" which is very slow to forward. If they click on the roundcube logo it goes right into the roundcube without any delay. Once inside roundcube they can view emails change folders without delay but if they hit compose a new email or reply to email they get a long delay.

Could it be some kind of reverse dns issue. I checked both of the dns servers in /etc/resolv.conf and both are working.

Or could the error:
2011-05-18 15:20:42 failed to expand condition "${if exists {$home/etc/$domain/quota}{${if > {${lookup{$local_part}lsearch{$home/etc/$domain/quota}{$value}{0}}}{0}{${if eq {${if exists {$home/mail/$domain/$local_part/maildirsize}{1}{0}}}{0}{${if > {${run {/usr/local/cpanel/bin/eximwrap GETDISKUSED $local_part $domain}}}{${lookup{$local_part}lsearch{$home/etc/$domain/quota}{$value}{0}}}{true}{false}}}{${perl{checkuserquota}{$domain}{$local_part}{$message_size}{${lookup{$local_part}lsearch{$home/etc/$domain/quota}{$value}}}{$home/mail/$domain/$local_part/maildirsize}}}}}{false}}}{false}}" for virtual_user_maildir_overquota router: integer expected but "[/home/{edited}/mail/{edited}.com/{edited user name}/maildirsize][33184][12]
38991493" found

But I think the above is related to another already reported issue. I am getting that for all users on this server not just a single domain.

BTW my support ticket number from them is #PMW-593522
 

Hack

Member
May 18, 2005
13
0
151
Hmm, found this is the /usr/local/cpanel/logs/error_log

-- RESTART MARKER (PID 25556 at 1305427141)--
[2011-05-14 22:39:01 -0400] warn [whostmgr2] Failed to download Addon whm version file at whostmgr/bin/whostmgr2 line 2742
main::getaddonversions('whm') called at whostmgr/bin/whostmgr2 line 2777
main::updateaddons() called at whostmgr/bin/whostmgr2 line 280
Building global cache for cpanel...Done
Building global cache for cpanel...Done
Building global cache for cpanel...Done
Building global cache for cpanel...Done
-- RESTART MARKER (PID 4338 at 1305720696)--
Building global cache for cpanel...Done
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Or could the error:
2011-05-18 15:20:42 failed to expand condition "${if exists {$home/etc/$domain/quota}{${if > {${lookup{$local_part}lsearch{$home/etc/$domain/quota}{$value}{0}}}{0}{${if eq {${if exists {$home/mail/$domain/$local_part/maildirsize}{1}{0}}}{0}{${if > {${run {/usr/local/cpanel/bin/eximwrap GETDISKUSED $local_part $domain}}}{${lookup{$local_part}lsearch{$home/etc/$domain/quota}{$value}{0}}}{true}{false}}}{${perl{checkuserquota}{$domain}{$local_part}{$message_size}{${lookup{$local_part}lsearch{$home/etc/$domain/quota}{$value}}}{$home/mail/$domain/$local_part/maildirsize}}}}}{false}}}{false}}" for virtual_user_maildir_overquota router: integer expected but "[/home/{edited}/mail/{edited}.com/{edited user name}/maildirsize][33184][12]
38991493" found
The error is one already reported, but it could possibly be causing issues for loading. The next build should fix that specific error.

That case is 49906 which is discussed in this thread - http://forums.cpanel.net/f43/case-49906-email-quota-error-after-upgrade-11-30-0-a-209452.html

To see when the case is incorporated into a build, you can view the changelog at Change Logs location. You can see the existing builds at Downloads - cPanel Inc. and your existing build by running:

Code:
cat /usr/local/cpanel/version