Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Smart Host - Exim Cpanel - SMTP external outgoing mail server

Discussion in 'E-mail Discussion' started by Stuart Elliot, Mar 18, 2016.

  1. Stuart Elliot

    Stuart Elliot Member

    Joined:
    Jan 3, 2016
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    I have the below setup that routes all outgoing mail from my server to an external service, Does anyone have any idea how i would modify this to so it will only use the below settings when emailing to outlook.com / outlook.co.uk ???

    Much help would be appriecated.. Thank you very much

    Section: AUTH
    smtp2go_login:
    driver = plaintext
    public_name = LOGIN
    client_send = : **** : ****

    Section: ROUTERSTART
    send_via_smtp2go:
    driver = manualroute
    domains = !+local_domains
    #ignore_target_hosts = !*.outlook.com
    #domains = *.outlook.com : *.outlook.co.uk
    transport = smtp2go_smtp
    route_list = * mail.smtp2go.com

    Section: TRANSPORTSTART

    smtp2go_smtp:
    driver = smtp
    port = 587
    hosts = mail.smtp2go.com
    hosts_require_auth = mail.smtp2go.com
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. double_t

    double_t Member

    Joined:
    Dec 2, 2007
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    53
    Stuart, did you find the solution to this ? thanks mate
     
  4. Stuart Elliot

    Stuart Elliot Member

    Joined:
    Jan 3, 2016
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    Yes pal, it was pretty simple. but took me about a month of googling and trying it all out.
     
  5. double_t

    double_t Member

    Joined:
    Dec 2, 2007
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    53
    Well ... can you help me ? I'm going nuts ! haha
     
  6. Stuart Elliot

    Stuart Elliot Member

    Joined:
    Jan 3, 2016
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    Yes, what do you need ? what is your setup, and which service are you sending mail through, and which addresses are you having issues sending too?
     
  7. double_t

    double_t Member

    Joined:
    Dec 2, 2007
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    53
    I just need to send **ALL OUTGOING ** emails to an external smarthost, but must be port 225 instead of 25, that's it
     
  8. Stuart Elliot

    Stuart Elliot Member

    Joined:
    Jan 3, 2016
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    in your any reason for using port 225 ?

    if you have WHM - goto exim config manager.
    Click Advanced Editor

    Search for "Section :AUTH" and below type in this

    smtp2go_login:
    driver = plaintext
    public_name = LOGIN
    client_send = : username : password

    Then Search for "Section: ROUTERSTART" and below type

    Section: ROUTERSTART
    send_via_smtp2go:
    driver = manualroute
    domains = !+local_domains
    transport = smtp2go_smtp
    route_list = * mail.externalmailserver.com

    DONT PASTE THIS // route_list = * sends all emails via above address
    DONT PASTE THIS // domain only sends to external people, so it still delivers locally if needed.


    Then Search for "Section: TRANSPORTSTART" and below type

    smtp2go_smtp
    driver = smtp
    port = 225
    hosts = mail.externalmailserver.com
    hosts_require_auth = mail.externalmailserver.com


    Any link to smtp2go is just a label! it doesnt matter as long as you put your external mail settings it, that setup should send all mail.
     
  9. double_t

    double_t Member

    Joined:
    Dec 2, 2007
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    53
    Worked like a charm ... I just use IP auth, so I didn't use your suggested auth settings .... thanks mate.

    I really like more Postfix ... in one single line like this you have t all done:

    relayhost = [gw.emailer.com]:225

    I do use port 225 due to internal auth system, not important the reason :)

    Thanks !
     
    cPanelMichael likes this.
  10. Stuart Elliot

    Stuart Elliot Member

    Joined:
    Jan 3, 2016
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    United Kingdom
    cPanel Access Level:
    Root Administrator
    Awesome FREE Help :) Glad i can help people..
     
    cPanelMichael likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice