osama.alani

Member
Oct 21, 2012
10
0
1
cPanel Access Level
Root Administrator
hello,
im getting below warning message :
S.M.A.R.T Errors on /dev/sda
From Command: /usr/sbin/smartctl -q errorsonly -H -l selftest -l error /dev/sda
Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
190 Airflow_Temperature_Cel 0x0022 070 039 045 Old_age Always In_the_past 30 (Min/Max 29/33)

ATA Error Count: 1
Error 1 occurred at disk power-on lifetime: 24082 hours (1003 days + 10 hours)
----END /dev/sda--

S.M.A.R.T Errors on /dev/sdb
From Command: /usr/sbin/smartctl -q errorsonly -H -l selftest -l error /dev/sdb
Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
190 Airflow_Temperature_Cel 0x0022 071 022 045 Old_age Always In_the_past 29 (Min/Max 28/30)

ATA Error Count: 4
Error 4 occurred at disk power-on lifetime: 5844 hours (243 days + 12 hours)
Error 3 occurred at disk power-on lifetime: 5844 hours (243 days + 12 hours)
Error 2 occurred at disk power-on lifetime: 5842 hours (243 days + 10 hours)
Error 1 occurred at disk power-on lifetime: 5842 hours (243 days + 10 hours)
----END /dev/sdb--

and data center said it is nothing to worry about as you see below


Dear Osama,



If you are receiving a notification from cPanel regarding a SMART airflow temperature attribute that failed In_the_past, this does not indicate that there is a problem with your server's drives. If you do not want to receive these emails, you will need to update your server's configuration to disable notifications related to this specific attribute. We are not able to assist with custom scripting or configurations, so I recommend reading the information in the following cPanel forum regarding this specific issue:

http://forums.cpanel.net/f5/smart-check-attribute-190-a-113513.html



could you please guide me in steps about how to disable or hide that warning message please ?


Thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

You can disable the S.M.A.R.T check by running the following command:

Code:
touch /var/cpanel/disablesmartcheck
Note that while it will prevent you from seeing the warning message you referenced, it will also not be able to send you additional warning messages about your hard drive in the event there is a different issue detected. You may want to create an email filter via cPanel that blocks that particular message instead.

Thank you.
 

osama.alani

Member
Oct 21, 2012
10
0
1
cPanel Access Level
Root Administrator
Hello :)

You can disable the S.M.A.R.T check by running the following command:

Code:
touch /var/cpanel/disablesmartcheck
Note that while it will prevent you from seeing the warning message you referenced, it will also not be able to send you additional warning messages about your hard drive in the event there is a different issue detected. You may want to create an email filter via cPanel that blocks that particular message instead.

Thank you.
Thanks a lot for fast response

but i just wonder can i just keep this option active for any further notification and i just clear history ?

Thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
You could configure and utilize "smartd" itself, as disable the S.M.A.R.T check used by cPanel. However, it's not possible to customize how the cPanel S.M.A.R.T check scans for problems. Feel free to open a feature request for this via:

Submit A Feature Request

Thank you.