The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Smart

Discussion in 'General Discussion' started by Bucanero, Jun 16, 2006.

  1. Bucanero

    Bucanero Member

    Joined:
    May 8, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    How do I enable smart for my drives ?

    Some servers with IDE drives already have it, but the ones with SCSI drives doesn't

    I get "S.M.A.R.T does not appear to be enabled for this device" on the cron logs

    Thanks

    Bucanero
     
  2. minotauro

    minotauro Well-Known Member

    Joined:
    Jan 19, 2004
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Hello Bucanero,

    To fix this problem, run the follow command:

    # touch /var/cpanel/disablesmartcheck

    Regards,
    Minotauro.
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That file has nothing to do with enabling SMART on IDE disks - that's something you have to do in the servers BIOS.
     
  4. dropby23

    dropby23 Well-Known Member

    Joined:
    Jan 16, 2005
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    hello i have a modified versiyon of smartcheck script and if you make this you can check the scsi status

    open /scripts/smartcheck file
    and fine this line
    Code:
    if($disk_enabled =~ m/\Q$smart{$vrs}->{'smart_enabled_rgx'}\E/i) {
    and change this line like this

    Code:
    if($disk_enabled =~ m/([SMART.])+.+enabled/i) {
    then chattr +i /etc/smartcheck than it will work fine
     
Loading...

Share This Page