Smarthost email sending problems

Operating System & Version
CentOS v7.9.2009 STANDARD kvm
cPanel & WHM Version
106.0.11

Mthokozisi

Registered
Dec 2, 2022
1
0
1
Johannesburg
cPanel Access Level
Root Administrator
I have configured Sendinblue as a smarthost on my GCP server as Google blocks port 25.

I've managed to send emails using Mailgun in the past until our company switched SMTP providers.
Now, our emails do not go out and display the error below when sending an email.

LOG: MAIN
cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1p0gUY-00049e-Th
delivering 1p0gUY-00049e-Th
Transport port=25 replaced by host-specific port=587
Connecting to smtp-relay.sendinblue.com.host.name.com [2606:4700:3035::ac43:deaf]:587 ... failed: Network is unreachable

I have used this guide to configure Sendinblue smarthost settings.
I'm not sure why it automatically adds my main domain at the end of: "smtp-relay.sendinblue.com"

I'd appreciate your help and expertise
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
161
23
93
Houston
cPanel Access Level
Root Administrator
Hi! I am not sure why your server would be adding the hostname onto the end of the smart host server. I was not seeing this same behavior happen when I tried to configure the smart host from the guide you linked. It's possible that another customization could be interfering. Have you tried backing up the Exim configuration, resetting it, then configuring the smart host to ensure no other customizations are in place that could interfere? We have an article that should guide you on how to backup and reset the Exim configuration:

How to backup, reset, and restore your Exim configuration