The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SmartHost for all but dedicated IPs

Discussion in 'E-mail Discussions' started by lockefaltaba, Jan 9, 2013.

  1. lockefaltaba

    lockefaltaba Member

    Joined:
    Oct 24, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,
    I've got a server which is delivering mail thru a Smarthost. However, recenlty added 2 more hostings which use their own dedicated IP (ssl). Now I urgently need to allow those dedicated to use their own IP instead of the smarthost for all the rest.

    I've googled everywhere and a bit lost :( ....nothing found

    Tnx every one in here :)
     
  2. lockefaltaba

    lockefaltaba Member

    Joined:
    Oct 24, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ok ....I'll give it a lil push :)

    We already have following code at /etc/exim.conf.local

    @ROUTERSTART@
    send_to_smart_host:
    driver = manualroute
    route_list = !+local_domains 1.2.3.4
    transport = remote_smtp

    Where 1.2.3.4 is our SmartHost. Do I have to add something else there or any other files/WHM options ? please ....I do not find any google info 'bout this.
     
  3. sonicthoughts

    sonicthoughts Well-Known Member

    Joined:
    Apr 4, 2011
    Messages:
    61
    Likes Received:
    3
    Trophy Points:
    8
    I'm trying to do what I think is the same thing: route all email, inbound and outbound, via google apps. Running several PHP programs that use sendmail and want it all to go via smtp.gmail.com. Seen several approaches (via iptables, exim, etc.) perhaps i need to submit a ticket?
     
  4. skyknight

    skyknight Active Member

    Joined:
    May 1, 2007
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    go to whm > Exim Configuration Manager and set

    * Send mail from account’s dedicated IP address > no
    * Reference /etc/mailips for outgoing SMTP connections > yes


    open /etc/mailips add this

    domain.tld: 1.1.1.1 (your ip)

    service exim restart

    test send mail
     
Loading...

Share This Page