smarthost IP resolves to IP on RBL

Operating System & Version
CENTOS 7.9
cPanel & WHM Version
92.0.8

danfbach

Member
Jan 14, 2021
9
1
3
United States
cPanel Access Level
Root Administrator
I've been working on an email deliverability issue for awhile (over 2 months) now and I've been getting sporadic reports that our email sending IP is on a black list, but when I search it on mxtoolbox, it is never on any blacklists...and also, email will deliver, then not deliver, then deliver...
SO, this brings me to today, I sent out an email and finally received an actual rejection response:
Code:
550-"JunkMail rejected - a2nlsmtp01-04.prod.iad2.secureserver.net 550 [198.71.225.38]:56732 is in an RBL"
a2nlsmtp01-04.prod.iad2.secureserver.net is the "smarthost" and resolves to anything in 198.71.225.0/24 subnet, some of which appear are blacklisted from time to time because presumably, whomever the smarthost network is shared with, sends out spam and gets blacklisted, which is detrimental to my emails deliverability for obvious reasons.
My server's IP is static and is a dedicated server. It does not send out any spam and should therefore never end up on a RBL...is it possible to just outright disable the smarthost configuration so that the smtp server exclusively uses my server and IP for outbound mail?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,968
612
273
cPanel Access Level
Root Administrator
Hey there! Sure, you can disable the smarthost configuration. Just reverse the steps that are about half way down this page:


and that will remove the entries from the Exim configuration for you.
 

danfbach

Member
Jan 14, 2021
9
1
3
United States
cPanel Access Level
Root Administrator
Actually, after further review, they're both already blank. All of the smarthost information seems to be under section: PREROUTERS... and yesterday i attempted to remove and leave the section blank which resulted in my smtp server being unable to deliver any email. I'm on a GoDaddy server and everything in the advanced config is as it came. The entry looks like this...
Code:
send_to_smart_host:
driver = manualroute
route_list = !+local_domains A2NLvphout-v01.shr.prod.iad2.secureserver.net
transport = remote_smtp
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,968
612
273
cPanel Access Level
Root Administrator
Thanks for the additional details. The "secureserver.net" domain is part of the GoDaddy network, so it's possible they have set this up on purpose to allow you to send mail on their network, which is often blocked by the provider. If that's the IP address you are seeing blocked you should contact them directly to let them know and see what they would propose for a solution, as you may not be able to remove that smarthost in your hosting environment.
 

danfbach

Member
Jan 14, 2021
9
1
3
United States
cPanel Access Level
Root Administrator
Yes, I'm aware that it is part of the GoDaddy network and I've tried talking to them and really their answer was essentially "let us know if you find anymore blacklisted ip's on our network but we can't help you adjust the configuration to disable the smarthost relay network."
So essentially, it is unresolvable because their default configuration prevents the disabling of their smarthost network, unless I were to get a dedicated smtp relay.

Thanks for your replies.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,968
612
273
cPanel Access Level
Root Administrator
I'm sorry to hear that was the conclusion on their end. There isn't a reason you couldn't reset the Exim configuration in WHM, but then you may not have the ability to send emails at all as they do block the standard port 25 on their side.

If the IP continues to be blacklisted, it might be worth it to use a third-party service for email.