The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMP hyperthreading on Centos???

Discussion in 'General Discussion' started by Snowman30, Apr 5, 2005.

  1. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    ive got a P4 3.2Ghz server which we have centos installed on and ive noticed that despite running a 2.4 smp kernel in the server information page in WHM it does not show the hyperthreaded kernels like it would under RHE or FC or RH9

    does this sound normal???
     
  2. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    Ask your server provider if the CPU is infact HyperThreaded and if so, if it is enabled in the BIOS.
     
  3. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Your sure its hypertheaded? what does rpm -qa | grep kernel show ? what about: uname -r and cat /proc/cpuinfo AND cat /etc/*release* ?
     
  4. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    yes its definately a hyperthreaded cpu

    and is running:

    uname is reflecting:

    and

    cat proc is showing:

     
  5. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Definitly check the bios settings.

    Edit: Also make sure you don't have anything such as "noht" appended to your bootloader.
     
  6. elJeffo

    elJeffo Registered

    Joined:
    Jul 28, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    We're seeind the same thing on select few of our servers, not running CentOS but SMP kernels for RH.. Suspect it might be certain Asus motherboards, but we're looking into it and I'll let you know what we find!
     
  7. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Which brings up a valid point i forgot to mention earlier. Are all bios ( and other ) firmware up to date ?
     
  8. BLazeD

    BLazeD Member

    Joined:
    Apr 9, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New Zealand
    I have exactly the same problem with my P4 2.8 - any news on it?
     
  9. Snowman30

    Snowman30 Well-Known Member
    PartnerNOC

    Joined:
    Apr 7, 2002
    Messages:
    681
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    In my case it turned out to be a faulty MB, a replacement was doen and it works perfectly now.

    As for the 2.8 i didnt think they ran in hyperthreaded mode???

    i thought it was the 3.02Ghz and upwards that did?
     
  10. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
  11. junglecat

    junglecat Well-Known Member

    Joined:
    Jul 6, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Yes, 2.8 can run in hyperthreaded mode, I have some that do. :cool:
     
Loading...
Similar Threads - SMP hyperthreading Centos
  1. Emmanuel Nieves
    Replies:
    2
    Views:
    326

Share This Page