The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP 0x800CCC0B error suggestion

Discussion in 'E-mail Discussions' started by tropotech, Jul 10, 2006.

  1. tropotech

    tropotech Registered

    Joined:
    Dec 15, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    I see many people have had specific problems with this particular error, and the inability to send email. Usually they receive something along the lines of:

    "An unknown error has occurred. Subject 'testing', Account: 'Bill Blog', Server: 'blog.com', Protocol: SMTP, Port: 25, Secure(SSL): No, Error Number: 0x800CCC0B"

    As a suggestion to others, in our experience, if the email catchall is set to
    ":fail: no such address"
    it immediately prevents our clients from being able to send email via their domain SMTP. (Does not affect those sending via their ISP's SMTP, but lets face it, if you have a domain, and with spam restrictions getting tighter ever day, who wants anything other than their domain to be noted as the sending SMTP?)

    Again, only in our experience, if we change the catchall to ":blackhole:" mail starts to send correctly again.
     
  2. richy

    richy Well-Known Member

    Joined:
    Jun 30, 2003
    Messages:
    276
    Likes Received:
    1
    Trophy Points:
    16
    I've never encountered that as a problem. Have your senders have got "My outgoing mail server requires authentication" turned on in Outlook AND are they logging into the POP3 server using the full email address?
     
  3. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    Agree with Richy - this error is typically a result of account misconfiguration in the email client -- not on the server. As suggested, verify users have referenced their full email address in the user name field, have indicated the account requires SMTP authentication, etc.

    In your sample above I also notice the refence to Port: 25, Secure(SSL). If you are going to have your clients use SSL for the SMTP connection, you need to have them change the port in their email client to 465.

    If any of the above do not take care of the problem, are they by chance running Norton AntiVirus? Some older versions can cause this error given the way NAVI scans outgoing mail. Try disabling and see if they changes things. And confirm their ISP allows the sending of mail on Port 25 (if you are not using SSL). This type of pop-up error can also take place when that happens.

    Lastly, do evertyhing you can to avoid using :blackhole: as the default address. You are (potentially) opening yourself up to huge server loads from spam attacks by not using :fail:

    Hope this helps -
     
  4. tropotech

    tropotech Registered

    Joined:
    Dec 15, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    Hi richy and RickG,
    And thanks for the feedback, but I think you missed my point.

    I was posting this as a guideline for others searching for this particular error, who are not getting their problems resolved by the suggestions you both make, which are already in other threads.

    Whilst good suggestions, and they do work for many, if you do a search of the forums on this particular problem, you will see just how many do not find those suggestions work for them.

    Our servers were in fact having this exact problem, and after much investigation, we discovered that by removing the ":fail: no such address" in our clients cpanel, instantly resolved their failing mail sending problem.

    As mentioned, ":blackhole:" in our particular case does not cause any problems at all, can't vouch that will work for other peoples servers though.

    I was mainly posting this for anyone searching the forums who reads the other threads but does not find a solution and cannot resolve their problems. Hopefully in that case, their particular server setup may mimic ours, and if they read this thread, they can check if their clients are using the :fail: catchall, if so, see if altering this cures their problem.

    I might add, this only applies to sending through their domains SMTP, if sending from their ISP's SMTP, the mail is handled correctly, and their domains POP3 bounces spam and junk that has bogus addresses perfectly whilst correctly addressed mail continues to travel to their inbox. But as I commented, I do not see the point of a client having a domain, and continuing to send their email via their ISP's mail servers.

    I suppose anyone having problems at the server should always check what they have set in the catchall area, but most server admins do not look there, as you would assume that has nothing to do with the SMTP only the POP3.

    I hope this will help someone out there in the future.
     
  5. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    Hopefully Jonathan will chirp in with a suggestion / explanation as to why changing the default address impacts this behavior.

    IMHO, I'd want to dig further. This seems to be a bandaid approach to fixing a problem (instinct still suggests misconfiguration) that should be corrected to get the system working "as designed,"
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It's not something I've ever come across. It does sound like a mis-configuration somewhere on the server if it exhibits that sort of problem since :fail: should have nothing to do with sending email. I'd suspect either an issue with valiases or mis-configured ACL's in exim.
     
  7. johnnyt

    johnnyt Registered

    Joined:
    Sep 12, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Same Problem

    I'm having the same issue. new install of Cpanel

    I setup the client myself to make sure it was setup correctly.

    I also recreated the email account in cpanel. Now when i hit send and recieve I get the same error and tried all the suggestion above.

    Can anybody else show me the light or what else to look for?

    Thanks
     
  8. RickG

    RickG Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    238
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    North Carolina
    Have you tried using a port other than 25?
     
  9. vasko

    vasko Member

    Joined:
    Apr 29, 2006
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    tropotech have you managed to verify this ? Were all e-mails delievered properly ?


    A customer of ours was not able to send e-mail to a specific mail box - mail@domain.com
    The error message from Outlook was:

    -------
    An unknown error has occurred. Subject 'test', Account: 'mail.customerdomain.com', Server: 'mail.customerdomain.com', Protocol: SMTP, Port: 25, Secure(SSL): No, Error Number: 0x800CCC0B
    -----
    There was no problem sending e-mails to other mail boxes. The bounce was "No such user here". The reason for this was simple - another customer was hosting, on the server,
    domain.com and since EXIM first checks the localdomain list for the recipient it finds that is hosted locally and tries to deliver the e-mail. No mail @domain.com[/bl] box exists so it returns the bounce.

    Here's another scenario, someone can host aol.com or comcast.com and then another
    person can try sending e-mails to his somename @aol.com/comcast.com box.
    Since those domains are hosted locally and since no such e-mail exists the mail will bounce. Of course this will happen only if :fail: No Such User Here is set as default catch-all of the sender. Changing that setting to :blackhole: may give the false impression for an e-mail delivery since there is no bounce.

    In my opinion :blackhole: should never be used. But this is just my opinion :)

    I hope this can help someone with similar problem. The solution is simple - check and see if there are any local records for the recipient's domain, check the httpd.conf file,
    check and see if there are any DNS records as well and always test with at least two mail clients.
     
Loading...

Share This Page