The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP and SSH Ports Not Responding

Discussion in 'General Discussion' started by Bestrafung, Apr 22, 2015.

  1. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I recently had an issue with the email server that required me to change the SMTP port in Outlook to 25 because 26 was no longer working. Upon looking into why port 26 wasn't working I have now found that I can no longer connect to SSH. I've tried restarting the SSH server from WHM but there's no change. I've verified that the public IP of my workstation isn't blacklisted and since I can access cPanel/WHM I didn't think it was anyway. As best I can tell the server hasn't been compromised and the root password is unchanged. I just simply cannot connect to the SSH port. Everything was working fine yesterday. Can anyone provide some information or pointers on where to begin to look into this?
     
  2. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Joined:
    Sep 23, 2013
    Messages:
    569
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Have you tried restarting sshd from within WHM? You can also try this via WHM:

    Code:
    http://SERVER_IP_ADDRESS:2086/scripts2/doautofixer?autofix=safesshrestart
    
    That should start a very basic sshd with a simple configuration that may let you connect.
     
  3. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Thank you very much! I had tried a restart but it made no difference. The safe restart script did the job. I guess something must have interfered with port 2022, it's working on 22 again.

    I'm still unable to connect to port 26 for SMTP. Do you have any ideas what may have caused this? This isn't a major issue but it seems to be necessary for some mobile devices.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    649
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Is port 26 enabled under "WHM Home » Service Configuration » Service Manager"? Also, have you ensured the port is open in your firewall configuration (or your CSF interface)?

    Thank you.
     
  5. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Yes, Exim Mail Server (on another port) is checked and set to 26. Everything has been working fine for over a year until recently. I'm not sure about the firewall, I don't know how it would have blocked itself after all this time but I will look into it.
     
  6. Bestrafung

    Bestrafung Active Member

    Joined:
    Apr 2, 2012
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Consider this thread resolved. I don't know how it changed after all this time but port 26 was somehow removed from the allowed ports list in CSF. All is well again. It also appears that port 2022 that I was using for SSH was also removed, the safe reset only worked because port 22 is allowed in CSF by default. Somehow CSF reset it's ports settings so I will keep an eye on it in the future and would suggest others do as well.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    649
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page