Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SMTP auth and reply-to

Discussion in 'E-mail Discussion' started by leonep, Apr 13, 2016.

  1. leonep

    leonep Well-Known Member

    Joined:
    Nov 18, 2014
    Messages:
    87
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Pescara
    cPanel Access Level:
    Root Administrator
    Hi,
    I have a little question for you.
    My customer have Exchange and want to use smarthost (my cpanel server) to send mails.
    They have configured exchange smarthost with SMTP Authentication using name and password (i have created an account on my cpanel server test@example.xxx ).
    The mail go correctly but the reply-to address is the email account used in smtp auth (test@example.xxx) for all the exchange emails account.....
    I want to know if cpanel forces the reply-to address to the one used in smtp auth config.
    How can i solve this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,726
    Likes Received:
    1,883
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Could you elaborate a little further on the behavior you are expecting? For instance, what email address are you excepting for the "Reply-To" address in the header?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leonep

    leonep Well-Known Member

    Joined:
    Nov 18, 2014
    Messages:
    87
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Pescara
    cPanel Access Level:
    Root Administrator
    client (emailAAA@xxx) -->exchange(LAN)-->smarthost(my CPANEL)(smtp auth with emailBBB@xxx)-->destination


    if destination click "reply-to" the email suggested is emailBBB and not the emailAAA . i got 20 different clients.

    I also have make more tests. if i put option "replyto" in the email client, the destination got wrong sender (emailBBB) but correct replyto address (emailAAA)

    second test i made with another smtp service (SMTP auth) it works correct sender=reply-to

    thanks !
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,726
    Likes Received:
    1,883
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Please let us know if changing any of the following options in "WHM >> Exim Configuration Manager" under the "Mail" tab alters the behavior you have reported:

    EXPERIMENTAL: Rewrite From: header to match actual sender
    Enable Sender Rewriting Scheme (SRS) Support


    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice