The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP Auth Stopped Working

Discussion in 'E-mail Discussions' started by DIYHosting, Jun 28, 2005.

  1. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    I just upgraded to the latest Edge build 10.4.0-E25 (with hopes that it would fix the missing cgi-bin ScriptAlias bug) and immediately after upgrading I could not send mail properly via SMTP unless I disabled the normal setting to authenticate with the SMTP server using the same login as my POP3 account.

    If I turn off SMTP Authentication, it will send properly.

    I tried reverting back to an older build, but this problem carried on over.

    Any idea on how to fix this? I just know that I'm going to get swamped with support tickets over this if people can't send mail as they always have without changing their Outlook settings to disable SMTP authentication.
     
  2. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    I should mention that with SMTP Auth turned on in Outlook, it will keep asking for the email address/password and not authenticate properly.

    I am also seeing this in exim_mainlog:

    2005-06-28 20:49:40 fixed_login authenticator failed for (XXXXX) [XX.XX.XX.XXX]:1763 I=[XX.XX.XX.XX]:25: 535 Incorrect authentication data (set_id=name@domain.com)
     
    #2 DIYHosting, Jun 28, 2005
    Last edited: Jun 28, 2005
  3. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    Looks like this has just been fixed in the new Edge-26 build. THANK YOU!
     
  4. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    I have the same problem here on one of my servers.
    I did not do any updates to break this but the Auth is broken server wide.
    I did an update to 10.4.0-E26 , reinstalled Exim, did a force on both as well but still broken.
    Any ideas ?
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Just had the same problem on a few of my servers. Do the following:

    /scripts/updatenow
    /scripts/eximup
     
  6. Bruce

    Bruce Well-Known Member

    Joined:
    Oct 4, 2001
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    /scripts/eximup must be a new script ?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    It replaced /scripts/exim4 a few months ago.
     
  8. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Sidman, PA
    hi,

    I ran this, but /scripts/eximup says exim is up to date. Should I do /scripts/eximup --force? I don't want to do this if it is not necessary.

    My issue is that authentication works, but is not required, and I would like authentication to be required.
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That's a different issue. If you want to force users to use SMTP AUTH you'd need to disable POP before SMTP (the antirelayd process). There have been several methods for doing this posted before, try a search for antirelayd.
     
Loading...

Share This Page