The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP bandwidth problem?

Discussion in 'E-mail Discussions' started by dariofg2, Apr 18, 2003.

  1. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    A client has complained that his SMTP bandwidth usage was way too high this month. He pointed out a specific day in which he received and sent very little e-mail and was told by the bandwidth meter he had transferred a total of 200 Mb!

    I checked exim_mainlog for his domain that day and he did have very, very little action, not even close to what you would expect from 200 Mb going back and forth!

    Is anyone else having the same problem? Is it going to be fixed in future Cpanel versions?

    -Dario
     
  2. macmartins

    macmartins Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Yes, I have the same problem with a client... the account have an excessive transfer, and the stats showed that it happened because the smtp traffic....but when I checked the smtp logs, it didn't appear any excessive traffic...

    I'm afraid and in a difficult situation with my client, because I can't prove him why happen that traffic...I think that cpanel is with an error in the smtp bandwidth, failing to calculate that... Is important get this problem solved quickly, because many clients of other cpanel users can stay with this same problem like my problem and like the problem that 'dariofg2' reported in his message!

    Anybody have this problem too?

    macmartins
     
  3. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    I think maybe the bandwidth counter is adding up attempted deliveries to the total number of bytes, instead of effectively delivered messages! I just checked another client's logs for a specific day, and he did not transfer anyway near the alleged 2 Gb!!!

    -Dario
     
  4. luis.gomes

    luis.gomes Registered

    Joined:
    Feb 6, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Same problem: Too much bandwidth for SMTP

    Same problem here!

    Clients are complaining because their limit are reaching too soon! I noticed the problem seems to be the wrong counting for SMTP usage.

    Does anybody knows how to solve this issue? I don't want to turn off the SMTP counting, 'cause too many clients are sending lots of email.

    :(
     
  5. macmartins

    macmartins Well-Known Member

    Joined:
    Feb 17, 2002
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Serious Problem!

    Yes, is a serious problem that must have quickly solution!

    Anybody have this problem, too?

    Mauricio
     
  6. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    I had to remove the bandwidth limit of several clients that were complaining about their SMTP bandwidth! What a headache!

    Nick, could you please check that?

    -Dario
     
  7. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    HELP!!! How do I turn this damn SMTP bandwidth off? Or at least is it going to be fixed any time soon???

    -Dario
     
  8. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    I FOUND THE BUG!!! Bandwidth is also being counted for messages that were NOT effectively delivered! For instance, take a look at this exim_mainlog entry:

    2003-04-21 14:36:19 196IB9-00017W-00 == XXXX@XXXX T=remote_smtp defer (110): Connection timed out: SMTP timeout while connected to mx.XXX.com [200.XXX.XXX.XXX] after DATA

    (XXX for anonymity). Although this message was NOT delivered, its byte size was added to the domain's SMTP bandwidth count!!!

    This is due to the fact that, as dictated in /etc/exim.conf, routers "lookuphost" and "literal", through the "condition" directive, call perl function "checkspam" (from /etc/exim.pl), which logs the bandwidth. But that happens BEFORE any attempt to deliver the message is made!

    I've commented out the SMTP bandwidth logging code from /etc/exim.pl as a quick fix. But when can we expect a definitive solution?

    -Dario
     
  9. X-Istencedotcom

    X-Istencedotcom Well-Known Member

    Joined:
    Apr 14, 2003
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    16
    If the mail bounces a lot and has like a 2 MB attachment i can see that go up a LOT.
     
  10. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    You're absolutely right, X-Istencedotcom!

    -Dario
     
  11. luis.gomes

    luis.gomes Registered

    Joined:
    Feb 6, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Dario, how do I fix /etc/exim.pl to stop counting my SMTP bandwidth?
     
  12. dariofg2

    dariofg2 Well-Known Member

    Joined:
    Mar 7, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Luis, edit /etc/exim.pl and comment out (add a # at the beginning of) the following lines:

    Code:
    open(DLOG,">>/usr/local/apache/domlogs/$domain-smtpbytes_log");
    print DLOG "$now $message_size .\n";
    close(DLOG);
    chmod(0640,"/usr/local/apache/domlogs/$domain-smtpbytes_log");
    -Dario
     
Loading...

Share This Page