Osama Tariq

Well-Known Member
Nov 27, 2014
206
2
18
Lahore, Pakistan
cPanel Access Level
Root Administrator
Twitter
Reverse dns doesn't match SMTP banner. How can i fixed it. Moreover our SMTP Transaction Time is not good, how can i make it good ?

By default following option is on in WHM:
"Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam"
 

Kailash1

Well-Known Member
Nov 27, 2006
255
2
168
cPanel Access Level
Root Administrator
Twitter
rDNS for your server's IP address should match to your server's hostname. If it is different, you get SMTP banner mismatch message. You can update your service provider to update rDNS for your server's IP to match it with hostname.
 

Kailash1

Well-Known Member
Nov 27, 2006
255
2
168
cPanel Access Level
Root Administrator
Twitter
By default, it uses server's primary IP address to relay email. You do not need to set same rDNS for all IP and it is not at all recommended configuration. If rDNS and server hostname are same, you should not receive SMTP banner mismatch warning.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
New But i have same rdns and hostname of primary ip of server but still shows smtp mismatch banner.
Hello,

Could you elaborate further on this? What's the specific error message you receive, and under which scenario are you receiving it?

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Reverse DNS does not match SMTP Banner
Hello,

Could you verify if the issue persists when temporarily disabling the "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam" option in "WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor"? I've seen reports that this option prevents third-party utilities such as MXToolBox from completing a check of the RDNS entry.

Thank you.
 

sawbuck

Well-Known Member
Jan 18, 2004
1,365
10
168
cPanel Access Level
Root Administrator
Hello,
Could you verify if the issue persists when temporarily disabling the "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam" option in "WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor"? I've seen reports that this option prevents third-party utilities such as MXToolBox from completing a check of the RDNS entry.
Thank you.
Took a long time to get here but I can confirm that turning off that option does indeed allow MXToolBox to complete the tests successfully and without errors/warnings.

Any reason to expect that to change in the future?

Adding the MXToolBox IP to the Trusted SMTP senders then wants to report the server is possibly an open relay. ;-)
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,215
363
Any reason to expect that to change in the future?

Adding the MXToolBox IP to the Trusted SMTP senders then wants to report the server is possibly an open relay. ;-)
This is something you could report to the developers of those utilities, as it's an issue they would have to address with their testing behavior.

Thank you.