The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP Error (-1): Connection to server failed.

Discussion in 'E-mail Discussions' started by pski, Feb 5, 2015.

  1. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    I have blocked some ports on my iptables, to confrom to PCI Compliant Scan Result. (25,26,110,143,587,3306,2077)

    I can login to an emali client using the SSL configurations, which is using the VPS domain instead of clients domain.

    aka. server.serverdomain.net instead of mail.clientdomain.com, which is present but for unsecured

    I am unable to send or receive email.

    any ideas? maybe a setting in whm exim? thanks
     
  2. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    The DataCenter told me it has to do with port 25 being closed, however that should not be the case..

    I tried to restart exim, and i get this result.
    Code:
    Exim MTA...
    Waiting for “exim” to restart …………waiting for “exim” to initialize ………finished.
    Service Status:
    Code:
         exim (/usr/sbin/exim -bd -q60m) running as mailnull with PID 23080 (pidfile check method)
    
    The service “exim” failed to send the expected response to host “127.0.0.1” and port “25” because an error: Timed out while trying to connect.
    Startup Log:
    Code:
         Starting exim: [  OK  ]
         0 processes (antirelayd) sent signal 9
         /usr/local/cpanel/scripts/update_sa_rules: running in background
    Log Messages:
    Code:
         2015-02-05 18:29:11 exim 4.84 daemon started: pid=23080, -q1h, listening for SMTP on port 25 (IPv4) port 26 (IPv4) port 587 (IPv4) and for SMTPS on port 465 (IPv4)
         2015-02-05 18:27:37 exim 4.84 daemon started: pid=22381, -q1h, listening for SMTPS on port 465 (IPv4)
         2015-02-05 18:22:34 exim 4.84 daemon started: pid=20650, -q1h, listening for SMTPS on port 465 (IPv4)
         2015-02-05 18:17:38 exim 4.84 daemon started: pid=17877, -q1h, listening for SMTPS on port 465 (IPv4)
         2015-02-05 18:17:31 exim 4.84 daemon started: pid=17546, -q1h, listening for SMTP on port 25 (IPv4) port 26 (IPv4) port 587 (IPv4) and for SMTPS on port 465 (IPv4)
    
    exim has failed. Please contact your system administrator if the service does not automagically recover.
    ...Done
     
    #2 pski, Feb 5, 2015
    Last edited by a moderator: Feb 5, 2015
  3. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    OK Another update:

    I found under Service Configuration > Service Manager > Exim Mail Server (on another port) I set this to 465

    and it restarted again, expect this time i got the error

    Service Status:
    Code:
    The service “exim” failed to send the expected response to host “127.0.0.1” and port “465” because an error: Timed out while waiting for a response.
     
  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    your DC is correct you blocked all your mail ports (25,26,110,143,587

    Port 465 is for smtps you set it to share it with 25
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The information your data center provided sounds accurate. Please see the following post:

    Blocking Port 25

    Thank you.
     
  6. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Ok so I have reset teh exim, and unblocked port 25 and 587 for the sake of things, mail seems to be working now.

    you mentioned set it to share port 25, i will have to look into that, I will submit another PCI scan if I can get to a comfortable spot tonight, and see what the results come back,
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page