Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SMTP error from remote mail server

Discussion in 'E-mail Discussion' started by takeno, Aug 10, 2018.

  1. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    My cPanel and WHM Version is v72.0.10
    In this month ,my smtp service got something wrong
    Some mail can be reply and some cant
    Please help me to find out possible reason
    Fail message as below

    Code:
    Event: failure
    Sender User: example
    Sender Domain: example.com.tw
    From Address: master@example.com.tw
    Sender: master@example.com.tw
    Sent Time: Aug 9, 2018, 8:25:20 PM
    Sender Host: www.example.com.tw
    Sender IP: 199.192.xxx.xx
    Authentication: dovecot_login
    Spam Score:
    Recipient: someusr@gmail.com
    Delivered To:
    Delivery User: -system-
    Delivery Domain:
    Router: dkim_lookuphost
    Transport: dkim_remote_smtp
    Out Time: Aug 9, 2018, 8:25:20 PM
    ID: 1fnk0F-00036q-Nc
    Delivery Host: gmail-smtp-in.l.google.com
    Delivery IP: 74.125.xxx.xx
    Size: 2.11 KB
    Result: SMTP error from remote mail server after end of data: 550 Action not taken
    
     
    #1 takeno, Aug 10, 2018
    Last edited by a moderator: Aug 10, 2018
  2. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @takeno

    More information than this would be necessary in order to tell you why your mail wasn't accepted by gmail. The output from the exim logs for the message ID in this instance would be extremely helpful. You could run something like:

    Code:
    exigrep 1fnk0F-00036q-Nc /var/log/exim_mainlog
    
    And let us know the output after removing any actual personal domain names/IP's

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    i tried find another new failed mail "1fpUBW-00050S-U"
    by
    Code:
    exigrep 1fpUBW-00050S-U /var/log/exim_mainlog
    and output is as below
    Code:
    2018-08-14 15:56:10 1fpUBW-00050S-UY <= master@example.com.tw H=(www.example.com.tw) [199.192.xxx.xx]:44426 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_login:master@example.com.tw S=1177 id=86279deb67974f57bee0d2d792571ed6@www.example.com.tw T="\351\233\266\350\202\241\345\200\211 \345\257\246\351\253\224\347\264\200\345\277\265\345\223\201\344\272\244\344\273\230\351\200\232\347\237\245\344\277\241" for someusr@gmail.com
    2018-08-14 15:56:10 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1fpUBW-00050S-UY
    2018-08-14 15:56:11 1fpUBW-00050S-UY Sender identification U=stockhousecom D=example.com.tw S=master@example.com.tw
    2018-08-14 15:56:11 1fpUBW-00050S-UY SMTP connection outbound 1534233371 1fpUBW-00050S-U example.com.tw someusr@gmail.com
    2018-08-14 15:56:12 1fpUBW-00050S-UY ** someusr@gmail.com R=dkim_lookuphost T=dkim_remote_smtp H=mx-tw.mail.gm0.yahoodns.net [180.222.103.9]: SMTP error from remote mail server after end of data: 550 Action not taken
    2018-08-14 15:56:12 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1fpUBW-00050S-UY
    2018-08-14 15:56:12 1fpUBY-00050w-SV <= <> R=1fpUBW-00050S-UY U=mailnull P=local S=2666 T="Mail delivery failed: returning message to sender" for master@example.com.tw
    2018-08-14 15:56:12 1fpUBW-00050S-UY Completed
    
    Thanks!
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    HI @takeno

    Is this happening with one specific account on your server or is it several? Can you ensure that the domain/s is present in /etc/localdomains or /etc/remotedomains?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    It happened in every account in my server,even in root
    many system mail or alert mail cant relay too

    I checked that you said,my domains all exist in /etc/localdomains
    and /etc/localdomains is empty

    Thanks
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @takeno

    That's good with the assumption that all mail *should* be received locally.

    Can you confirm that the primary IP (as well as all IP's on the server) has a valid PTR record? The PTR or rDNS should resolve the IP address back to the hostname of the server. You can identify this by running the following command:

    Code:
    host <YourIPHere>
    The result should match your hostname.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    Yes.i have set PTR record,it wasted me many time,my DNS register is godaddy,and godaddy cant set PTR record.
    Finally i found I can set PTR in VPS Management Platfaorm.
    I used mxtoolbox to check,and sure PTR is correctly now.

    I don`t know if it connect with this question.
    Yeserday i got dmarc mail from yahoo and google at same time .
    Content is as below
    Code:
    <?xml version="1.0" encoding="UTF-8" ?>
    <feedback>
      <report_metadata>
        <org_name>google.com</org_name>
        <email>noreply-dmarc-support@google.com</email>
        <extra_contact_info>https://support.google.com/a/answer/2466580</extra_contact_info>
        <report_id>7400435419999342150</report_id>
        <date_range>
          <begin>1534118400</begin>
          <end>1534204799</end>
        </date_range>
      </report_metadata>
      <policy_published>
        <domain>example.com.tw</domain>
        <adkim>r</adkim>
        <aspf>r</aspf>
        <p>none</p>
        <sp>none</sp>
        <pct>100</pct>
      </policy_published>
      <record>
        <row>
          <source_ip>199.192.XX.XXX</source_ip>
          <count>4</count>
          <policy_evaluated>
            <disposition>none</disposition>
            <dkim>fail</dkim>
            <spf>fail</spf>
          </policy_evaluated>
        </row>
        <identifiers>
          <header_from>server1.example.com.tw</header_from>
        </identifiers>
        <auth_results>
          <spf>
            <domain>server1.example.com.tw</domain>
            <result>none</result>
          </spf>
        </auth_results>
      </record>
      <record>
        <row>
          <source_ip>199.192.XX.XXX</source_ip>
          <count>4</count>
          <policy_evaluated>
            <disposition>none</disposition>
            <dkim>fail</dkim>
            <spf>fail</spf>
          </policy_evaluated>
        </row>
        <identifiers>
          <header_from>example.com.tw</header_from>
        </identifiers>
        <auth_results>
          <dkim>
            <domain>example.com.tw</domain>
            <result>fail</result>
            <selector>default</selector>
          </dkim>
          <spf>
            <domain>example.com.tw</domain>
            <result>none</result>
          </spf>
        </auth_results>
      </record>
    </feedback>
    Thanks.
     
  8. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @takeno

    That DMARC response indicates that both SPF and DKIM verification checks failed for example.com.tw

    Can you confirm that both records are present?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. asconsulting

    asconsulting Member

    Joined:
    Aug 15, 2018
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    We have had an identical experience starting around August 10th as well. Same error message, and it's sporadic. Sometimes the messages work, sometimes they don't. SPF are valid, and DKIM isn't being used.

    PTR records are in place and valid as well.
     
  10. asconsulting

    asconsulting Member

    Joined:
    Aug 15, 2018
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Here are some details from the error message:
    Delivery Host: [removed]
    Delivery IP: [removed]
    Size: 19.92 KB
    Result: 25 I=[162.255.117.152]:58950: SMTP error from remote mail server after end of data: 550 Action not taken

    The IP in the results line is the server's IP.

    When a message get's rejected all recipients are rejected, even local email addresses. We have a BCC going to an internal email that also fails.
     
  11. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @asconsulting
    Why are you not utilizing DKIM? Some email service providers will reject DKIM verification failures for domains that have invalid configurations or none at all.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. asconsulting

    asconsulting Member

    Joined:
    Aug 15, 2018
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Because the clients use several outside services, like Mail Chimp and Constant Contact to send as well. We are working on setting that up, but it has been a slow process getting complete answers from clients. The weird thing is that it all recipients fail, the BCC works sometimes and not for others. Also the very generic error 550 instead of a rejection message with details.

    Also, I have checked remotedomains and localdomains and things seem to be where they should be.
     
  13. asconsulting

    asconsulting Member

    Joined:
    Aug 15, 2018
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I have setup DKIM on one of the domains that was having issues. I verified the DKIM via MX Toolbox. The emails are still failing. I am getting the same error as before just now it says "dkim_lookuphost" and "dkim_remote_smtp" instead of "lookuphost" and "remote_smtp".
     
  14. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @asconsulting

    What are your DNS resolvers set to? You can see these via SSH by running the following:

    Code:
    cat /etc/resolv.conf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. asconsulting

    asconsulting Member

    Joined:
    Aug 15, 2018
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    ; generated by /sbin/dhclient-script
    nameserver 8.8.8.8
    nameserver 4.2.2.3
     
  16. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    I confirmed spf and DKIM recoed.
    I found i set spf and DKIM in dns txt record's name seem wrong.
    I set spf and DKIM txt record 's name is example.com.tw,and mxtoolbox show no spf record.
    I change name to @ from my domain ,now mxtoolbox can see my spf and DKIM record.
    Hope this can solve my question.i will report it if my qustion solved.

    Thanks.
     
  17. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    I think your issue might be a bit different @asconsulting
    Can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


    Great! We'll be looking forward to an update from you either way.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    I think my question have beed solved.
    Thanks for helping
     
  19. takeno

    takeno Member

    Joined:
    Aug 10, 2018
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    taiwan
    cPanel Access Level:
    Root Administrator
    Sorry,I am wrong,550,action not taken happened again.
    Please see these 2pics below.
    2018/08/21 2:26~2:28 in 3mins,i sent 19mails,and 7 failed,12 successed.
    Fail and success happened in same recipient,you can see gn019XXXX@gmail.com and yamanXXXX@gmail.com have fail and success both.

    Thanks
    057.jpg

    056.jpg
     

    Attached Files:

    • 057.jpg
      057.jpg
      File size:
      198.1 KB
      Views:
      2
  20. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,871
    Likes Received:
    280
    Trophy Points:
    193
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @takeno


    Can you double check the DKIM for that domain? It doesn't seem to be valid (I ran the query with your domain name but removed it in my response)

    Code:
    $ dig txt default._domainkey.yourdomain.com.tw +short
    $
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice