Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SMTP Exim slow, timeouts & connection lost

Discussion in 'E-mail Discussion' started by walterdevos, Sep 30, 2016.

Tags:
  1. walterdevos

    walterdevos Member

    Joined:
    Apr 30, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    51
    Hi

    Brand new server (vps) install and configuring Exim. I noticed a lot of these lines in de exim_main.log

    Code:
    2016-09-30 16:20:14 SMTP connection from [46.183.220.150]:48721 lost
    I couldn't find anything on the internet, so I let it be.

    But when I let mxtoolbox check the SMTP configuration, it came back with:
    SMTP Transaction Time 15.427 seconds - Not good! on Transaction Time
    SendSMTPCommand: Timeout waiting for response after 15 seconds.​

    In the exim_main.log this was logged:
    Code:
    2016-09-30 16:18:18 SMTP connection from pws3.mxtoolbox.com [64.20.227.134]:55736 lost
    I tried logging in with telnet port 25
    Between "connected to" and "220" was almost 20 seconds.

    I found out that the setting " Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam. " in the Exim Basic editor ACL options was de culprit. When I disabled that option, mxtoolbox reported:
    SMTP Connection Time 0.855 seconds - Good on Connection time
    Is there a way to make that setting a little less aggressive? Like 5 seconds delay, not 20, because most SMTP clients time out.

    Thanks
     
    #1 walterdevos, Sep 30, 2016
    Last edited by a moderator: Nov 8, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,961
    Likes Received:
    1,821
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    20 seconds was found to be the most effective, however you can customize that value in your Exim configuration file. Here are the sections to modify:

    Code:
    #BEGIN ACL_PRE_RECIPIENT_BLOCK
              # BEGIN INSERT delay_unknown_hosts
    
    warn
      !authenticated = *
      !hosts = : +neighbor_netblocks : +loopback : +trustedmailhosts : +recent_authed_mail_ips : +backupmx_hosts : +skipsmtpcheck_hosts : +senderverifybypass_hosts : +greylist_trusted_netblocks : +cpanel_mail_netblocks
      #only rate limit port 25
      condition = ${if eq {$received_port}{25}{yes}{no}}
      delay = 20s
    
    # END INSERT delay_unknown_hosts

    Code:
    #BEGIN ACL_CONNECT_BLOCK
    # BEGIN INSERT delay_unknown_hosts
    
    
    warn
        !hosts = : +neighbor_netblocks : +loopback : +trustedmailhosts : +recent_authed_mail_ips : +backupmx_hosts : +skipsmtpcheck_hosts : +senderverifybypass_hosts : +greylist_trusted_netblocks : +cpanel_mail_netblocks
        #only rate limit port 25
        condition = ${if eq {$received_port}{25}{yes}{no}}
        delay = 20s
    
    
    # END INSERT delay_unknown_hosts
    Information on custom Exim ACL changes is available at:

    Exim Configuration Manager - Documentation - cPanel Documentation

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    walterdevos likes this.
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice