SMTP: Failed to write to socket: not connected

engineer4a

Registered
Jul 29, 2019
1
0
1
Kuala Lumpur
cPanel Access Level
Website Owner
I have error "There was an error sending an event notification: Failed to set sender: [email protected] [SMTP: Failed to write to socket: not connected (code: -1, response: )]" when I am trying to send an event to attendees but I am receiving and sending emails fine.
Please advise
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
It sounds like there may be an issue with CardDav on the server if you don't have root access you'd need to let your provider know the error you're receiving and they should be able to provide you with further assistance.
 

ganesankittan

Member
Jul 30, 2019
11
2
3
Coimbatore
cPanel Access Level
Website Owner
I have error "There was an error sending an event notification: Failed to set sender: [email protected] [SMTP: Failed to write to socket: not connected (code: -1, response: )]" when I am trying to send an event to attendees but I am receiving and sending emails fine.
Please advise
Please check if exim service is running and also check if ports are blocked on firewall end and also reload the exim service with the below commands.

ps -aux | grep exim
service exim restart

Also check "SMTP_Block" option in CSF configuration file.

Make sure that "SMTP_Block" is set to "0". So that it will not Block outgoing SMTP.

Restart CSF Firewall once the changes have been made.

Give this a try and post back with the errors you have identified and we shall try to resolve it.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
@ganesankittan

As noted in the initial response mail is able to be sent/received without issue. The issue is event notifications, this would rule out an issue with SMTP Block in CSF (if they're able to send/receive mail this wouldn't be the issue). Furthermore, the user doesn't have access to stop and start exim and in this case, if exim is functioning they shouldn't need to.

Thank you.