The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP Fails over Mobile Network

Discussion in 'E-mail Discussions' started by dsh, Oct 13, 2015.

  1. dsh

    dsh Registered

    Joined:
    Oct 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Ontario
    cPanel Access Level:
    Root Administrator
    Hello all,

    Firstly I want to apologize if this isn't the type of question to be posted here, but I have found very little help throughout this forum and around the web.

    A client of mine brought up an interesting bug with my server's configuration. It started late last week when she got a new phone and I helped her set up her email on it. We had successfully set up IMAP and SMTP on her desktop mail client with no issues. When she attempted to send an email from her phone however, she was blocked. She came to my office a few days later and I inputted all the settings with the same results. I connected her phone to my office's wifi and all of a sudden she could send emails just fine.

    So I checked my own phone out. We use the same server, but have different domains and obviously different usernames. I get the same problem, I cannot send over my carrier's network. We are both located in Canada, and using different mobile carriers (her Fido, me Virgin).

    The darnedest thing is that I can still receive email, and that when I'm on wifi I can send it.

    So to confirm, we are using the same server location for IMAP and SMTP, along with the ports and security settings recommended when looked up in cPanel (IMAP: 993, SMTP 465). Please note that these settings work on WiFi, and desktop email clients.

    I looked up my IP address when using the LTE connection from my carrier and ran this command on my server:

    Code:
    # exigrep "PHONE_IP_ADDRESS" /var/log/exim_mainlog
    And noticed this peculiar failure line:

    Code:
    +++ 1Zm12H-0006PW-6H has not completed +++
    2015-10-13 10:58:41 1Zm12H-0006PW-6H H=([IP_I_DON'T_RECOGNIZE]) [PHONE_IP_ADDRESS]:40754 X=TLSv1.2:DHE-RSA-AES128-GCM-SHA256:128 CV=no F=<my_email@example.com> A=dovecot_plain:my_email@example.com rejected after DATA: host lookup failed (failed to find host name from IP address)
    Ah, so a failed hostname lookup for that IP address seems to be the issue. What exactly is that about? Is it a setting that should be on to deter spam? Where would I go to address this issue? Any advice is greatly appreciated,

    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The issue is there's no RDNS record configured for that IP address. Please report this to the phone provider so they can address the issue. You can also browse to the "Access Lists" tab in "WHM >> Service Configuration >> Exim Configuration Manager" and add the IP address to the "Trusted SMTP IP addresses" list to see if that helps.

    Thank you.
     
  3. dsh

    dsh Registered

    Joined:
    Oct 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Ontario
    cPanel Access Level:
    Root Administrator
    Thanks for your response Michael.

    I have considered this but it will also require me to contact the technical support of every carrier here in Canada and acquire all of the IP addresses they use, for no carrier will let SMTP authenticate over their data networks.

    Edit: I have tried to add my phone's IP address to the "Trusted SMTP IP" lists to no avail.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. dsh

    dsh Registered

    Joined:
    Oct 13, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toronto, Ontario
    cPanel Access Level:
    Root Administrator
    Hey,

    The user was sending mail outside of our server, as well as internally. I should update this post to add that I was finally able to get mail to send after commenting out exim's option to verify the hostname of the sending IP. Because our mobile carriers don't have a hostname in the reverse lookup of an IP, none of them would send. I so hope this doesn't gravely impact the security of our email server.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Additional information on enabling or disabling reverse host verification is found at:

    Reverse DNS Lookup

    Thank you.
     
Loading...

Share This Page