The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP + Google apps

Discussion in 'E-mail Discussions' started by Mark_CFH, Nov 19, 2013.

  1. Mark_CFH

    Mark_CFH Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    One of our clients is using google apps (email) for their emails. All the information needed was entered how it is suppose to be. In which its not working, they contacted Google apps about the issue, in which google apps stated its a server problem. The error that cpanel is giving is as follows:

    "Please turn on SMTP Authentication in your mail client. ourserver.server.com (domain here) [serverIP]:42878 is not permitted to relay through this server without authentication."

    Is there some setting on cPanel that you need to turn on SMTP Auth for this to work ? Or is it something that has nothing to do with the server, but the software being used (Joomla)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you elaborate on where you are seeing this error message, and what steps you take to reproduce it? Is it only through the PHP script, or does it happen in other instances?

    Thank you.
     
  3. Mark_CFH

    Mark_CFH Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    It shows the messages when viewing the Mail Trace in the cPanel account.

    cPanel > Mail > Email Trace:

    Code:
    Please turn on SMTP Authentication in your mail client. server.name.com (www.website.com) [serverIP]:35514 is not permitted to relay through this server without authentication.
    
    The MX Entry that is needed is setup correctly via Google Apps setup.

    And adding
    Code:
    v=spf1 ip4:ServerIP include:_spf.google.com ~all
    
    Under Advanced DNS Editor
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you let us know how you are reproducing the issue beyond just the email trace feature in cPanel? Also, keep in mind that email for this domain name is not hosted on the cPanel if you are using a remote MX record.

    Thank you.
     
  5. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    If using Google Apps, the mail should not be going through the cpanel server. All mail flows through Google's servers.
    The only setting to be aware of is to put your cpanel server's IP address in the SPF (usually taken care of with 'a', but putting the IP doesn't hurt), and have the IP listed in the 'accepted' servers in Google Apps dashboard. This will help make sure any emails sent from your website (contact form, etc) are 'allowed' to be sent from the server.

    I also try to make sure that the SPF allows for any IPs of mailing services like ConstantContact.
     
  6. Mark_CFH

    Mark_CFH Well-Known Member

    Joined:
    Apr 2, 2013
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I think we have got this issue figured out. It was a setting that when reading over it, it basically says "do not touch" lol. Referring to SMTP Restrictions being turned off, and Antirelayd being enabled.

    We wish there was another way around this, but it doesnt appear as such.
     
  7. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    Is the error coming from Joomla trying to send an email? By default, Joomla uses PHP on the server to send mail out. That's why I put the IP address in SPF. But, if the user setup Joomla to login to an outside mailserver, I guess the problem could be there. I've never done that in Joomla, as using PHP has worked all the time.

    I manage many Joomla sites and Google Apps, and I haven't had an issue. It might be just something simple.
     
  8. ScatSpeak

    ScatSpeak Registered

    Joined:
    Nov 4, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    Hi Mark_CFH! I realize that this issue was quite some time ago, but can you provide any more details about what was done to correct it?

    I'm having a similar issue after migration from Postini to Google Apps and changing of my domain MX settings for compatibility with Google required changes - but all incoming email to the domain bounces when Google attempts to push it into the domain.

    What did you do to fix your problem? TIA!
     
Loading...

Share This Page