Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP issues

Discussion in 'E-mail Discussions' started by xanadu, Feb 11, 2017.

  1. xanadu

    xanadu Member

    Joined:
    Sep 25, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    This is the situation:

    myownserver1.com can receive mail on all cpanel accounts and can send emails when using the ISP outgoing mail server or by using webmail. However, if we attempt to use mail.myownserver1.com as the outgoing server address we gat a 503 error.

    If we transfer a cpanel account that has had this issue to another of our servers, myownserver2.com, and without changing any email client settings, it all works fine.

    I have exhausted my knowledge with WHM and cannot find a problem with thw SMTP server settings......Help anyone?

    CORRECTION> Transferring a cPanel Account to another server does NOT make any difference.

    Do I have a DNS issue?
     
    #1 xanadu, Feb 11, 2017
    Last edited by a moderator: Feb 11, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know the specific error message you receive, and the corresponding output in /var/log/exim_mainlog when this happens?

    Thank you.
     
  3. xanadu

    xanadu Member

    Joined:
    Sep 25, 2006
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    Thank you for your response.

    The error message is:
    Code:
    'xxxxxxx@xxxxx.org.au' on 14/02/2017 4:47 PM
    
    503 Valid RCPT command must precede DATA'
    
    From exim_mainlog:
    2017-02-14 16:46:57 H=c110-20-92-214.rivrw9.nsw.example.com.au (somename) [110.20.xx.xx]:56531 F=<xxxxx@domain.net.au> rejected RCPT <xxxxx@xxxx.org.au>: Rejected relay attempt: '110.20.xx.xx' From: 'xxxxx@domain.net.au' To: $
    2017-02-14 16:47:00 H=c110-20-92-214.rivrw9.nsw.example.com.au (somename) [110.20.xx.xx]:56531 Warning: "Detected session with all messages failed"
    2017-02-14 16:47:00 H=c110-20-92-214.rivrw9.nsw.example.com.au (somename) [110.20.xx.xx]:56531 Warning: "Increment slow_fail_block Ratelimit - c110-20-92-214.rivrw9.nsw.domain.com.au (somename) [110.20.xx.xx]:56531 becaus$
    2017-02-14 16:47:00 SMTP connection from c110-20-92-214.rivrw9.nsw.example.com.au (somename) [110.20.xx.xx]:56531 closed by QUIT
    
    Hope that all helps you help me!
     
    #3 xanadu, Feb 14, 2017
    Last edited by a moderator: Feb 14, 2017
  4. sktest123

    sktest123 Well-Known Member

    Joined:
    Jan 31, 2017
    Messages:
    76
    Likes Received:
    5
    Trophy Points:
    8
    Location:
    kochin
    cPanel Access Level:
    Root Administrator
    503 Valid RCPT command must precede DATA' seems to be authentication issues for mail relaying (remote smtp)
    "503 Valid RCPT command must precede DATA essentially means that the server was unable to accept the message, usually because the SMTP connection was not properly authenticated. In cPanel/WHM servers, authentication can happen either through POP-before-SMTP or through SMTP authentication. If the user has not configured Outlook for outgoing mail SMTP authentication, and has not connected to the POP server before sending the mail, this error is returned".
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The "Valid RCPT command must precede DATA" error message typically suggests SMTP Authentication is not enabled in the email client. For instance, with Outlook, this typically happens when "My SMTP server requires authentication" isn't enabled.

    Thank you.
     
    ItsMattSon likes this.
Loading...

Share This Page