SMTP monitoring connection lost as of 15/10/2015

djjelly

Registered
Mar 14, 2013
3
0
1
cPanel Access Level
Root Administrator
Hello,
My dedicated server hosting provider is using a monitoring service for various services one of which is SMTP. As of yesterday's Cpanel update WHM 11.52.0 (build 15) the monitoring is reporting that SMTP is down even though it isn't.

After inspecting the exim_mainlog I can see that:
Until yesterday monitoring SMTP connections where closed like:
2015-10-14 21:32:45 SMTP connection from [95.154.xxx.xxx]:56365 (TCP/IP connection count = 1)
2015-10-14 21:32:45 no host name found for IP address 95.154.xxx.xxx
2015-10-14 21:32:45 SMTP connection from [95.154.xxx.xxx]:56365 closed by QUIT

and from today they are like:
2015-10-15 22:26:15 SMTP connection from [95.154.xxx.xxx]:63373 (TCP/IP connection count = 1)
2015-10-15 22:26:15 no host name found for IP address 95.154.xxx.xxx
2015-10-15 22:26:25 SMTP connection from [95.154.xxx.xxx]:63373 lost

Looking at the updates that run overnight, I went from 11.50.2.2 to 11.52.0.15 - could you please advise what could be the change that affect the way the monitoring connection is getting lost?

I hope you'll be able to help
Thanks in advance.
 
Last edited by a moderator:

PenguinInternet

Well-Known Member
PartnerNOC
Jun 20, 2007
190
22
68
Cardiff, UK
cPanel Access Level
DataCenter Provider
Twitter
This is covered in the release notes and just needs an timeout adjustment: 11.52 Release Notes - Documentation - cPanel Documentation

Warning

If your external monitoring system reports failures after you update your server to cPanel & WHM version 11.52, configure your monitoring system to allow 45 seconds timeout for connections to port 25. (Read your monitoring system's documentation for how to adjust the timeout and polling settings.)

If that does not resolve the problem, add the IP address of your monitoring system to the Trusted SMTP IP Addresses section of WHM's Exim Configuration Manager interface (Home >> Service Configuration >> Exim Configuration Manager).

If you still encounter errors on your monitoring system, disable the Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam setting in the Basic Editor section of WHM's Exim Configuration Manager interface (Home >> Service Configuration >> Exim Configuration Manager). However, this will likely result in an increase in spam that your server receives.
 

djjelly

Registered
Mar 14, 2013
3
0
1
cPanel Access Level
Root Administrator
Thank you Penguin.
As I don't have access to the monitoring system to configure it I have now added the monitoring systems IP to the whitelist. The exact location for the whitelist is:
"Exim Configuration Manager > Basic > Access Lists > Trusted SMTP IP addresses"

Thanks for your response I can mark this Solved!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

I am happy to see the issue is now resolved. Thank you for updating us with the outcome.