The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMTP not working>??

Discussion in 'E-mail Discussions' started by aboyz, Jan 30, 2005.

  1. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    I'm using outlook express to retrieve my email from cpanel. I can't seem to send out any email but i can recieve email. All SMTP account not working since last night. What is going on any fixed??

    The connection to the server has failed. Account: 'mail.domain.com', Server: 'mail.domain.com', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10060, Error Number: 0x800CCC0E

    What is going on?? all people using pop3 cannot send out any email. please help

    thanks
     
  2. mrcbrown

    mrcbrown Well-Known Member

    Joined:
    Jun 5, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    A majority of SoCal is offically prevented from using port 25 on SBC services - if you are on DSL as your connection this 'could' be the issue - I have recently had to go into the service manager and open a new port as well as in the firewall as more clients who use DSL are noting this issue - they can POP fine, just no SMTP.

    Not sure if that helps - but at least it's a possiblity.
     
  3. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    same here

    same here..

    i gotta changed all my smtp port to 26 not everything is working. damn. I mean isn't the smtp server using the server itself and nothing to do with the provider? I mean when you try to send a email using outlook. it look for the smtp server which is on the cpanel. know what i mean. I mean how does it got to do with anything with the ISP you are using. It just doesn't make sense. I mean it make sense if you are using your ISP smtp server, but in this case nothing to do with your ISP. as the send mail being routed to your cpanel box know what i'm trying to say??
     
  4. ckh

    ckh Well-Known Member

    Joined:
    Dec 6, 2003
    Messages:
    356
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Phoenix, AZ
    cPanel Access Level:
    DataCenter Provider
    Your ISP is blocking port 25 so that you can't connect to your smtp server. They are forcing you to use their email servers.

    My ISP blocks both ports 25 and 26 so I run exim on port 27 which does allow me to send email. If they block 27, I'll use another port... :D
     
  5. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    i see what u mean now

    I totally see what you mean now. all ISP block those port, so i can't connect to my smtp server thats why i can't send out email!!! make excatly sense to me.. What if I use my ISP smtp server to spam!! ahhahahaha
     
  6. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    So just setup an alternate port to use for those who have their isps blocking port 25... I use 225. You have to have root access to the server, of course. If you don't you'll have to ask whomever does. It's easy to do through WHM.

    I think isps that block port 26 are just looking out for their own interests, and annoying their customers... as there's no reason to block that port. Whereas blocking port 25 stops viruses and automated spamming worms from sending out mail to the rest of the internet.

    Then they'll immediately know it was you and disconnect your service, and possibly take legal action against you. It's a bit harder to track it down if you can spam out from port 25 direct to other mailservers.
     
  7. Dacsoft

    Dacsoft Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Melbourne, Florida
    It might not be your ISP. I know that is the easy answer, but I just started having this problem on 2 different accounts. I have about 10 on the same server - so I doubt it is my ISP.
     
  8. jerickson

    jerickson Registered
    PartnerNOC

    Joined:
    Dec 13, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    If your having this issue on 2 out of several servers, make sure that you don't have a configuration set where you can only access the mail server for a certain ammount of sessions, for those that have 10 different e-mail accounts, I would recommend setting up forwards and filters on your e-mail client, to limit the number of connections that you are making to your server.
     
  9. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    To test if your ISP is blocking port 25 . . .

    There's often a lot of unknowns in situations such as this and so one of the first steps when troubleshooting such an issue is to check if your ISP is blocking port 25.

    This can be done very easily by trying to connect to your server on port 25 using telnet and seeing what response you get back. If you see anything relating to your ISP, or more specifically anything that doesn't look like its coming from your SMTP server, then your ISP will be blocking port 25. This is also assuming that you don't get any errors, timeouts or the like.

    Here's how to do it on a Windows-based PC from the command prompt (although any telnet client would do just as well):

    Code:
    telnet example.com 25
    An average Cpanel server running Exim will then respond in a following fashion (this is what my server responds with):

    Code:
    220-example.com ESMTP Exim 4.44 #1 Mon, 14 Mar 2005 10:49:48 +0000
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    If you get a valid response back (i.e. not a timeout or any other error) and it refers to the name of your ISP, they are blocking port 25.
     
Loading...

Share This Page