Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SMTP Port

Discussion in 'E-mail Discussion' started by dennis00, Apr 20, 2005.

  1. dennis00

    dennis00 Member

    Joined:
    Nov 9, 2002
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    How do I change the SMTP-port EXIM uses?

    My ISP blocks port 25, so I cannot use my server to send mail. I have to use my ISP's mailserver instead.

    How do I change the smtp-port of my server?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    WHM > Service Manager > exim on another port > check and specify another port. You mkust still have exim running on port 25 otherwise you will never receive remote email.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dennis00

    dennis00 Member

    Joined:
    Nov 9, 2002
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    Keeps on crashing:
    2005-04-20 20:14:52 socket bind() to port 10000 for address (any IPv4) failed: Address already in use: waiting before trying again

    Killing processes in netstat -natep | grep 10000 and restarting Exim did not help. :(
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Sounds like you've already got something bound to that port. Try a different one or shutdown whatever it is that you have bound to 10000 already.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. dennis00

    dennis00 Member

    Joined:
    Nov 9, 2002
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    151
    Very strange. It's working now when I use port 10950.

    The only difference is... the first time I had first set the SMTP-port in WHM and than I opened this port (10000) in APF.

    This time I first opened the port (10950) in APF and then changed the port in WHM from 10000 to 10950. It is now working.

    Thanks dude :)
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice