The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

smtp problem

Discussion in 'E-mail Discussions' started by Daniz, Jul 15, 2005.

  1. Daniz

    Daniz Member

    Joined:
    Apr 1, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I tried searching the forum but all I could find was this that should give a clear view of the problem

    :;;;;;;;;;;;;;;
    Most of your clients probably don't realise it, but when they POP their emails accounts, their IP address is stored in a file for 30 minutes. If they then attempt to send an email through the server, their IP address is checked against said list and if it is valid, they can relay. If not, they get an error indicating that they need to POP their email first.
    :;;;;;;;;;;;;;;

    So my problem is this: In thunderbird I set 'use SSL' for the pop3 which works fine until I want to send an email. The error I get is that I need to POP my mail first which I do repeatedly without any success. If I turn of the SSL, do a POP and then try to send it gets sent. This is a very bad solution since it's pretty meaningless to turn of SSL every time I want to send an email. Hepe someone can help me out.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The way around that (which is probably caused by the cPanel use of stunnel to create the SSL login) is to use SMTP AUTH instead of POP before SMTP as your authentication method for relaying.
     
  3. Daniz

    Daniz Member

    Joined:
    Apr 1, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    hi chirpy,
    thanks for the answer could you tell me howto enable the auth and disable the pop be for send? all I see is the "Verify the existance of email senders" which I guess is the pop before send ?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    SMTP AUTH is enabled by default on all cPanel servers. You simply need to modify your email client to use it. For example, in Outlook you need to get through to Internet Email Settings > Outgoing Server > tick My outgoing server (SMTP) requires authentication > then you can usually also seletc > Use same settings as my incoming mail server > otherwise use the same username and password that you POP with normally.

    You can only disable POP before SMTP properly in the latest EDGE release where it has been included in WHM > Service Manager
     
  5. Daniz

    Daniz Member

    Joined:
    Apr 1, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    worked out great. I never used the auth since I had alot of problems with the mail accounts before so I totally forgot about using it agian when finally fixing it all.
    thanks.
     
Loading...

Share This Page