The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

smtp reset

Discussion in 'E-mail Discussions' started by shapedesign, Nov 23, 2008.

  1. shapedesign

    shapedesign Registered

    Joined:
    Nov 23, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Grand Haven Michigan
    I am very new to this site, and I am sure that there is a problem with the server and not a local problem.

    I have about 47 accounts on my server, and every morning I have to do a graceful reset because none of my customer can send out email using outlook or any other mail client. You can use webmail to send and receive, but using a mail client you cannot send, this is not a local problem at all have already tested all areas.

    It seems to happen in the mornings, and all I have to do is reset the server and that resets everything, and everything will work. This is also the only issue I am having. You just cannot send mail using a mail client, until I reset the server then you can.

    any hints?

    rw
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    If the server is running the latest version of cPanel you might check the EXIM configuration section in WHM to make sure there is no notice about needing reset. If you see that, follow the instructions provided there. (you should have recieved an email about this from your server is this is needed)

    Not sure if that's any help, but worth a peek to be sure.
     
  3. shapedesign

    shapedesign Registered

    Joined:
    Nov 23, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Grand Haven Michigan
    There are no messages at all from what I can see, I just don't get it though, after I reset the server everything seems to work good, I will keep on this though it is a pain to have to reset all the time.

    Thank you for your reply
    rw
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,451
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  5. shapedesign

    shapedesign Registered

    Joined:
    Nov 23, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Grand Haven Michigan
    Need Everyones attention

    If you read this thread you can pretty much get the idea that I am having a heck of a time trying to figure this one out, not only that but it is just becoming really a pain, but I am 100% sure that it can be resolved if we could get more people involved in the issue.

    The only problem that I am having trouble with, is that no matter how you look at it, the problem starts between the hours of 2am to 4am, during a system check maybe? I and send emails all day long, customers can send emails all day long, but in the mornings, I have to reset the server to reset something in the system, I am thinking it has to do with a automatic reset, that is not working, because if I set it on my own, everything works for almost 24 hours, then I have to reset it again.

    problem is, that no matter what I do, or how I do it, the problem is always there, and I am trying to find the answers to the problem. The system seems to just shut off the smtp of any mail client, and then seems to happen only in the early mornings. Of course then I have to reset the server.

    any more help out there?
     
  6. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    I probably do not have an answer so to speak, just thinking out loud to your call for help, instead of restarting the entire server have you tried to just restart individual services like

    IMAP Server (Courier/Dovecot)
    Mail Server (Exim)

    One at a time, restart one then try to send mail via the mail client. It might be a little easier and save some time on the restart as opposed to a reboot.

    Also you might run crontab -e (Ctrl+x to exit) from ssh to see what is running between 2 and 4 am look for the second place in the code indicated here by red color
    i.e. * 2 * * * commandhere
    i.e. * 3 * * * commandhere
    i.e. * 4 * * * commandhere
    look for a 2, 3, or 4

    Maybe something is a miss there when a cron runs
     
Loading...

Share This Page