The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

smtp response unknown email address within the server/domain

Discussion in 'E-mail Discussions' started by eeadmin, Dec 2, 2004.

  1. eeadmin

    eeadmin Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    I have a situation when a client sends an email to an uknown addressee on thier own domain and therefore own server they do not get a reply rejection message. Instead, they get an SMTP error at the mail client level, outlook. This error typically halts all email sending and further email sending out via outlook. The users are usually stumped by this for a couple of days before they call anybody. The emai just piles up. I know this is per the RFC, but is there a way around that.

    Current default/blackhole was set to :fail: no such address at this domain.

    If I set up the default/catchall to dump to blackhole. The problem goes away but the end user never knows what has really happened. So essentially what the client would like to see is the user message is sent peacefully without any SMTP error. Without cloggin up poor old outlook. Then they would get a message later that said this user doesn't exist. For them this could be really useful. They have a lot of internal emails.

    The kicker is I'd like to do this for this specific domain only. Yet I'll take any solutions people have to offer.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    As you say, this is perfectly correct behaviour and the problem is with the email client, not with the mail server or its configuration. It's simply rejecting the email at the RCPT stage due to the non-existent account.

    You can get around this, but it would take a bit of work inside the ACL section of exim.conf where you have the verify = recipient command. That would need to be subject to a domain condition check, i.e. only do it if it's not this domain.

    It shouldn't be that difficult, but might take a little bit of time getting it right. I might have a play in a while to come up with something if you're not interested in finding out yourself ;)
     
  3. eeadmin

    eeadmin Well-Known Member

    Joined:
    Oct 21, 2004
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dallas, TX
    smpt rejected

    I'd love any help I can get on this issue. exim.conf I don't have any confidnece with it.

    We are pretty active with this client. Is there a a setting on the mail client we could change. We know the IT guy over there pretty good. We could get in and start tinkering with the machines. I think they all use Outlook Express.
     
Loading...

Share This Page