Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED SMTP restrictions option false after server restart

Discussion in 'E-mail Discussion' started by tehnec, Dec 12, 2017.

Tags:
  1. tehnec

    tehnec Registered

    Joined:
    Dec 12, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zagreb
    cPanel Access Level:
    Root Administrator
    Hello, I have noticed a little inconsistency when playing with "SMTP restrictions" option. When I disable the option in WHM -> security center and restart the server, the option in WHM shows that it is still disabled, but actually, the option has been re-enabled in the background. I have to enable/disable it again to take effect.

    Is there a way to make this change permanent, regardless of server restart?

    I didn't find any documentation on what this option actually does, and are there any config files associated with it. I'm running Centos7.4 / WHM 68.0.19.

    Any help would be appreciated, Thx.
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,531
    Likes Received:
    1,965
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I was unable to reproduce this issue on a test system using the same environment. Could you run the following command and let us know the output?

    Code:
    systemctl status firewalld
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tehnec

    tehnec Registered

    Joined:
    Dec 12, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Zagreb
    cPanel Access Level:
    Root Administrator
    Hi, I don't use firewalld, I use iptables instead, so the command's output was:
    Code:
    Unit firewalld.service could not be found.
    but I did some further iptables configuration checks and figured out where the problem was.
    As it happens, I had an old iptables configuration loaded automatically at boot time, and in that configuration, the SMTP restrictions were enabled.
    So every time I rebooted the system, the old configuration kicked in.

    Sorry if I wasted your time, Thank you.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,531
    Likes Received:
    1,965
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I'm glad to see you were able to determine the cause of the issue. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice