SMTP2Go issue: sending as localhost?

jjdewit

Member
Nov 6, 2020
7
0
1
Netherlands
cPanel Access Level
Root Administrator
Hi all,

Today i installed SMTP2Go as the email relay service of choice. I followed the manual closely but it seems that WHM is not routing the emails through them.
Here are two of the email delivery reports:

Report #1, sent through Gmail where a POP3 box is created and sent to a Gmail address:
--

Delivery Event Details
Event: defer warning
Sender User: mydomainhosting
Sender Domain: mydomain.com
From Address: [email protected]
Sender: [email protected]
Sent Time: Jan 28, 2021, 7:40:19 PM
Sender Host: mail-yb1-f178.google.com
Sender IP: 209.85.219.178
Authentication: dovecot_plain
Spam Score:
Recipient: [email protected]
Delivered To:
Delivery User: -system-
Delivery Domain:
Router: send_via_smtp2go
Transport: smtp2go_smtp
Out Time: Jan 28, 2021, 7:40:19 PM
ID: 1l5CD6-0007dB-3T
Delivery Host:
Delivery IP:
Size: 1.37 KB
Result: retry time not reached for any host for 'gmail.com'
--

This is report #2, from a notification of a WordPress website:
--

Delivery Event Details
Event: defer warning
Sender User: affiliate
Sender Domain:
From Address: [email protected]
Sender: affiliate
Sent Time: Jan 28, 2021, 7:42:19 PM
Sender Host: localhost
Sender IP: 127.0.0.1
Authentication: localuser
Spam Score:
Recipient: [email protected]
Delivered To:
Delivery User: -system-
Delivery Domain:
Router: send_via_smtp2go
Transport: smtp2go_smtp
Out Time: Jan 28, 2021, 7:42:19 PM
ID: 1l5CF7-0007q6-AN
Delivery Host:
Delivery IP:
Size: 1.14 KB
Result: retry time not reached for any host for 'gmail.com'
--

SMTP2Go support team thinks it has to do with some setting in WHM but was not able to determine what causes this error and suggested to reach out to more technical people.

Does anyone here happen to know what causes email not to be routed through SMTP2Go?

Thanks in advance
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,418
1,001
313
cPanel Access Level
Root Administrator
Hey there! In your output, the "router" and "transport" do seem to indicate that SMTP2Go is being used for the connection. From looking through their guide it seems that it still uses Exim to handle the initial message, so can you check the mail logs at /var/log/exim_mainlog to see if there are additional details about this error present there? If you see the "Retry time not reached" inside the Exim log directly I'd recommend running these commands to clear the retry database:

Code:
/usr/sbin/exim_tidydb -t 0d /var/spool/exim retry > /dev/null
/usr/sbin/exim_tidydb -t 0d /var/spool/exim reject > /dev/null
/usr/sbin/exim_tidydb -t 0d /var/spool/exim wait-remote_smtp > /dev/null
 

jjdewit

Member
Nov 6, 2020
7
0
1
Netherlands
cPanel Access Level
Root Administrator
The issue was port related. The WHM guide on their website states that port 2525 should be used, but changing the port to another one solved the problem. For me it was port 587 that worked.

TLS port numbers: 8025, 587, 80, or 25.
SSL is available on ports 465, 8465, and 443.

After I found another log with more detailed info, the support assistant at SMTP2Go came up with the idea of trying a different port. Support team is very fast in responding to my ticket, despite being in different timezones.

Thank you cpRex as well, for replying with your suggestions.
 
Last edited: