SMTPUTF8 is required, but was not offered by host

dandadude

Well-Known Member
Apr 14, 2011
51
1
58
Hi!

A client of mine reported that he cannot receive mail from someone who can send to other servers without a problem.
I asked for the log and the problem is this in their postfix log:
"SMTPUTF8 is required, but was not offered by host"

It is not clear for me what I need to do. I have found a support link (https://support.cpanel.net/hc/en-us/articles/360053824393-How-to-use-SMTPUTF8-with-Exim), but it is not clear to me if setting these two options have any caveats/disadvantages:
allow_utf8_domains = true
smtputf8_advertise_hosts = *

Thanks for the help!

Regards,
Daniel
 

dandadude

Well-Known Member
Apr 14, 2011
51
1
58
Thanks very much!
Then may I ask why this is not default?
(since the default behaviour does not let some e-mail get to my client)

Hey there! I'm not aware of any disadvantages to enabling these options. These just allow Exim to use unicode headers in the mail messages.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,027
313
cPanel Access Level
Root Administrator
I think at this point it's not the default just because it never has been, so many users may not be expecting that. If you'd like to submit a feature request so our team could review setting this as the default, that would likely be the best way to move forward. You can do that through the link in my signature.
 
  • Like
Reactions: dandadude