The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sni.conf rebuilding errors

Discussion in 'E-mail Discussions' started by outpostmm, Jul 17, 2015.

  1. outpostmm

    outpostmm Member

    Joined:
    Dec 3, 2008
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have a problem similar to this one, but not the same thing and I notice a fix in the changelog for this issue but it didn't address what I'm seeing:

    https://forums.cpanel.net/threads/c...-certificate-without-sni-mail-enabled.455382/

    On only one of our servers out of 6, it looks like when we update an SSL certificate the /etc/dovecot/sni.conf file does not get rebuilt correctly. I get the same error messages reported in that thread - that certain .cert files don't exist. The error is correct, the files in the conf file do not exist. I fix the issue by going to the cert and key directories and copying and pasting those cert and key filenames into the conf file. This latest time, the cabundle was also using an incorrect filename.

    So, it appears that the sni.conf file either does not get rebuilt at all, or it gets rebuilt with incorrect (old?) information. I believe that the file is getting rebuilt, because when I open it there may be more entries than the last time I fixed it, but it's not using the correct filenames.

    This is on a server running 11.50.0.25. This is only happening on one of our production servers, and it only occurs when a certificate is updated or installed. It also appears that updating any certificate causes errors in all of the rest (for example, we update a certificate on one of three accounts, but in sni.conf the .cert and .key filenames for all three accounts are incorrect, not just the one that was updated).
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you let us know if this issue persists on cPanel version 11.50.1.1? There's another case included that might help address this issue:

    Fixed case FB-187033: Clean up Mail SNI map files when uninstalling SSLS for Addon Domains.


    It's currently only available in the "Current" build tier.

    Thank you.
     
Loading...

Share This Page