SlapHappy

Member
Jul 8, 2014
15
1
53
cPanel Access Level
Reseller Owner
WordPress: 5.9.2
Plugins Installed: None

PHP version: EA-74
(php74-php-snuffleupagus - Installed)


We have noticed this week that a clean install of WordPress with no other plugins throws the error below when the Site Health link is clicked from the Dashboard.
After some testing of the same simple install we noted the same error can occur randomly. When creating/editing a page etc.

Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function 'curl_setopt', because its argument '$option' content (81) matched the rule 'Please don't turn CURLOPT_SSL_VERIFYHOST off.' in /home/xxxxxxx/public_html/wp-includes/Requests/Transport/cURL.php on line 152

Is the Snuffleupagus module/extension actually compatible with WordPress at this time?

I also cite this cPanel page: Why would you need a workaround for every WordPress website that wants to run a "current" version of PHP.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
10,971
1,728
363
cPanel Access Level
Root Administrator
Hey there! I'm not sure it's entirely compatible, as the developer mentions WordPress issues specifically on his page:

"This feature breaks web applications doing checks on the serialized representation of data on their own, like WordPress."

The official WordPress workaround, instead of adjusting their code, is to adjust the Snuffleupagus ruleset:


so it seems neither side wants to give in on this.

Right now it's important to note that this is in our Experimental repository, with an example link here:

http://203.174.85.202/cpanelsync/re...-snuffleupagus-0.7.0-2.2.33.cpanel.x86_64.rpm

and our team is still evaluating if this will become a permanent part of the product or not.