The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Softlayer blocked 25. Trying to get "Smarthost" works

Discussion in 'E-mail Discussions' started by neverknowhk, Mar 4, 2016.

  1. neverknowhk

    neverknowhk Registered

    Joined:
    Feb 8, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello all,

    Recentl, Softlayer decided to block all the Port 25 for email so it end up I can't use my cpanel mail server to send email anymore.

    My server is located in US with 100tb. They provided me a guide to set up a new email server and guide to setup to use "Smarthost" in my cpanel.

    Here is the guide url:-

    100tb.com/community/knowledgebase/display/HOW/Configuring+SMTP+Relay+Server


    I have added the new mail server ip into the cpanel server and successfully got the mail server up and running. Email sent thru perfectly in my new mail server but when I try to send email from the cpanel. It gave me error

    Here is the command and error message:

    Code:
    # echo "my message" | sendmail [EMAIL]destination@domain.com[/EMAIL]
    
    
    2016-03-04 16:37:10 cwd=/ 2 args: sendmail [EMAIL]destination@domain.com[/EMAIL]
    2016-03-04 16:37:10 1abyLO-0003ST-Io <= [EMAIL]root@server.com[/EMAIL] U=root P=local S=362 for [EMAIL]destination@domain.com[/EMAIL]
    2016-03-04 16:37:10 cwd=/ 3 args: /usr/sbin/exim -Mc 1abyLO-0003ST-Io
    2016-03-04 16:37:10 1abyLO-0003ST-Io ** [EMAIL]destination@domain.com[/EMAIL] R=fail_remote_domains: The mail server could not deliver mail to [EMAIL]destination@domain.com[/EMAIL].  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
    2016-03-04 16:37:10 cwd=/ 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1abyLO-0003ST-Io
    2016-03-04 16:37:10 1abyLO-0003SY-MU <= <> R=1abyLO-0003ST-Io U=mailnull P=local S=1392 T="Mail delivery failed: returning message to sender" for [EMAIL]root@server.com[/EMAIL]
    2016-03-04 16:37:10 1abyLO-0003ST-Io Completed
    2016-03-04 16:37:10 cwd=/ 3 args: /usr/sbin/exim -Mc 1abyLO-0003SY-MU
    2016-03-04 16:37:10 1abyLO-0003SY-MU User 0 set for local_delivery transport is on the never_users list
    2016-03-04 16:37:10 1abyLO-0003SY-MU == [EMAIL]root@server.com[/EMAIL] R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    
    Please give me some advice. Really Appreciated
     
    #1 neverknowhk, Mar 4, 2016
    Last edited by a moderator: Mar 4, 2016
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,475
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Not exactly. You might consider making some changes to your setup:

    WHM »Service Configuration »Service Manager, Exim Mail Server (on another port)
    Add port 587 there, be sure to add that port to your firewall as well.
     
  3. neverknowhk

    neverknowhk Registered

    Joined:
    Feb 8, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply.

    I have already added the 587 or even 26 port into my cpanel.

    "tcp 0 0 :::587 :::* LISTEN 31343/exim "

    but my email ended up in the "Mail Queue Manger"

    it has been stayed in there for hours. I asked the support and they said 587 is not blocked and I have already disabled the firewall in my server.

    so any more hints for that?
     
    #3 neverknowhk, Mar 4, 2016
    Last edited: Mar 4, 2016
  4. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    I would recommend opening a support ticket to get this resolved. There could be a number of tweak settings, exim configurations, or even firewall settings that could be blocking from doing what you want.

    cPanel Customer Portal

    Thanks!
     
Loading...

Share This Page